summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-03-19 16:32:30 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-09-14 23:22:34 +0200
commite0eb9f7f85c56815c25c2873591d1290b21c67dc (patch)
tree92a3a274473785ad197855c0d92d22a0950f698d /app-vim/ebnf-syntax
parentapp-vim/easy-align: EAPI8 bump (diff)
downloadgentoo-e0eb9f7f85c56815c25c2873591d1290b21c67dc.tar.gz
gentoo-e0eb9f7f85c56815c25c2873591d1290b21c67dc.tar.bz2
gentoo-e0eb9f7f85c56815c25c2873591d1290b21c67dc.zip
app-vim/ebnf-syntax: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-vim/ebnf-syntax')
-rw-r--r--app-vim/ebnf-syntax/ebnf-syntax-1.1-r3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-vim/ebnf-syntax/ebnf-syntax-1.1-r3.ebuild b/app-vim/ebnf-syntax/ebnf-syntax-1.1-r3.ebuild
new file mode 100644
index 000000000000..c657db10f5a8
--- /dev/null
+++ b/app-vim/ebnf-syntax/ebnf-syntax-1.1-r3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: EBNF (ISO/IEC 14997) file syntax highlighting"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=545"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting for EBNF (ISO/IEC 14997) files."
+
+src_prepare() {
+ default
+
+ # don't use hi link, bug #101799.
+ sed -i -e 's,hi link,hi def link,' syntax/ebnf.vim || die "sed failed"
+}