summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-03-26 13:36:55 -0400
committerTim Harder <radhermit@gentoo.org>2016-03-26 13:40:26 -0400
commit02bf33462c1688491fea99f86a62094b326a5906 (patch)
treefde4c12b55f0a997f60f89d080b01d726c88221f /app-vim/gundo/gundo-2.6.1.ebuild
parentnet-irc/quassel: Remove old (diff)
downloadgentoo-02bf33462c1688491fea99f86a62094b326a5906.tar.gz
gentoo-02bf33462c1688491fea99f86a62094b326a5906.tar.bz2
gentoo-02bf33462c1688491fea99f86a62094b326a5906.zip
app-vim/gundo: version bump to 2.6.1
Diffstat (limited to 'app-vim/gundo/gundo-2.6.1.ebuild')
-rw-r--r--app-vim/gundo/gundo-2.6.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/gundo/gundo-2.6.1.ebuild b/app-vim/gundo/gundo-2.6.1.ebuild
new file mode 100644
index 000000000000..f645812289bd
--- /dev/null
+++ b/app-vim/gundo/gundo-2.6.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="vim plugin: visualize your vim undo tree"
+HOMEPAGE="https://sjl.bitbucket.org/gundo.vim/"
+SRC_URI="https://github.com/sjl/gundo.vim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+
+RDEPEND="|| ( app-editors/vim[${PYTHON_USEDEP}] app-editors/gvim[${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}"
+
+S=${WORKDIR}/${PN}.vim-${PV}
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ rm -r .gitignore .hg* package.sh README* site tests || die
+}