summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-13 21:18:23 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-14 20:23:14 +0100
commite18842a9aabd9a2ab876a19944a4773affdb4e25 (patch)
tree80094c4adb7eee0bf67a85f01fe52b04b0a20d3a /dev-build/tinycmmc/tinycmmc-9999.ebuild
parentMove {dev-util → dev-build}/rocm-cmake (diff)
downloadgentoo-e18842a9aabd9a2ab876a19944a4773affdb4e25.tar.gz
gentoo-e18842a9aabd9a2ab876a19944a4773affdb4e25.tar.bz2
gentoo-e18842a9aabd9a2ab876a19944a4773affdb4e25.zip
Move {dev-util → dev-build}/tinycmmc
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-build/tinycmmc/tinycmmc-9999.ebuild')
-rw-r--r--dev-build/tinycmmc/tinycmmc-9999.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-build/tinycmmc/tinycmmc-9999.ebuild b/dev-build/tinycmmc/tinycmmc-9999.ebuild
new file mode 100644
index 000000000000..8bbe616423ad
--- /dev/null
+++ b/dev-build/tinycmmc/tinycmmc-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Grumbel/${PN}.git"
+else
+ SRC_URI="https://github.com/Grumbel/${PN}/archive/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Tiny CMake Module Collections"
+HOMEPAGE="https://github.com/Grumbel/tinycmmc"
+
+LICENSE="ZLIB"
+SLOT="0"