summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-26 17:33:32 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-26 17:33:32 +0100
commit425a3370ceec445d3bf176b088d38e99dfa19ff7 (patch)
treeb3cb4d9bab9e75309f795632fc62713832a76ca4 /dev-cpp/catch/catch-2.1.1.ebuild
parentapp-antivirus/clamav: x86 stable (bug #645794) (diff)
downloadgentoo-425a3370ceec445d3bf176b088d38e99dfa19ff7.tar.gz
gentoo-425a3370ceec445d3bf176b088d38e99dfa19ff7.tar.bz2
gentoo-425a3370ceec445d3bf176b088d38e99dfa19ff7.zip
dev-cpp/catch: Version bump to 2.1.1
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'dev-cpp/catch/catch-2.1.1.ebuild')
-rw-r--r--dev-cpp/catch/catch-2.1.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-cpp/catch/catch-2.1.1.ebuild b/dev-cpp/catch/catch-2.1.1.ebuild
new file mode 100644
index 000000000000..d7763c4ccaa9
--- /dev/null
+++ b/dev-cpp/catch/catch-2.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+inherit cmake-utils
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/catchorg/Catch2.git"
+else
+ MY_P=${PN^}2-${PV}
+ SRC_URI="https://github.com/catchorg/Catch2/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+
+ S=${WORKDIR}/${MY_P}
+fi
+
+DESCRIPTION="Modern C++ header-only framework for unit-tests"
+HOMEPAGE="https://github.com/catchorg/Catch2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCATCH_ENABLE_WERROR=OFF
+ -DBUILD_TESTING=$(usex test)
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
+ )
+ cmake-utils_src_configure
+}