summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-24 11:45:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-24 11:45:09 +0100
commitd426e7a18be312662bd29c6813cc9fe41ecf6e9c (patch)
tree62882556ad6801d90ac9b366cbf33bd464f1fe31 /dev-cpp/eigen
parentsys-auth/elogind: drop 246.10-r4 (diff)
downloadgentoo-d426e7a18be312662bd29c6813cc9fe41ecf6e9c.tar.gz
gentoo-d426e7a18be312662bd29c6813cc9fe41ecf6e9c.tar.bz2
gentoo-d426e7a18be312662bd29c6813cc9fe41ecf6e9c.zip
dev-cpp/eigen: Restrict tests
Otherwise we will never be able to stabilise anything here. Bug: https://bugs.gentoo.org/927892 Bug: https://bugs.gentoo.org/932646 Bug: https://bugs.gentoo.org/943401 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-cpp/eigen')
-rw-r--r--dev-cpp/eigen/eigen-3.4.0-r3.ebuild14
-rw-r--r--dev-cpp/eigen/eigen-9999.ebuild12
2 files changed, 13 insertions, 13 deletions
diff --git a/dev-cpp/eigen/eigen-3.4.0-r3.ebuild b/dev-cpp/eigen/eigen-3.4.0-r3.ebuild
index 7b368f254261..ca9fcf23a441 100644
--- a/dev-cpp/eigen/eigen-3.4.0-r3.ebuild
+++ b/dev-cpp/eigen/eigen-3.4.0-r3.ebuild
@@ -82,8 +82,13 @@ IUSE_TEST_BACKENDS=(
IUSE="${CPU_FEATURES_MAP[*]%:*} clang cuda hip debug doc lapack mathjax test ${IUSE_TEST_BACKENDS[*]}" #zvector
-# Tests failing again because of compiler issues
-RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ test? ( !lapack )
+ || ( ${IUSE_TEST_BACKENDS[*]} )
+"
+
+# Tests failing again because of compiler issues; bugs #932646, #943401
+RESTRICT="test !test? ( test )"
BDEPEND="
doc? (
@@ -142,11 +147,6 @@ DEPEND="
)
"
-REQUIRED_USE="
- test? ( !lapack )
- || ( ${IUSE_TEST_BACKENDS[*]} )
-"
-
PATCHES=(
"${FILESDIR}/${PN}-3.3.9-max-macro.patch"
"${FILESDIR}/${PN}-3.4.0-doc-nocompress.patch" # bug 830064
diff --git a/dev-cpp/eigen/eigen-9999.ebuild b/dev-cpp/eigen/eigen-9999.ebuild
index b4f6ac524ee0..6b434b04723c 100644
--- a/dev-cpp/eigen/eigen-9999.ebuild
+++ b/dev-cpp/eigen/eigen-9999.ebuild
@@ -82,8 +82,12 @@ IUSE_TEST_BACKENDS=(
IUSE="benchmark ${CPU_FEATURES_MAP[*]%:*} clang cuda hip debug doc lapack mathjax test ${IUSE_TEST_BACKENDS[*]}" #zvector
-# Tests failing again because of compiler issues
-RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ || ( ${IUSE_TEST_BACKENDS[*]} )
+"
+
+# Tests failing again because of compiler issues; bugs #932646, #943401
+RESTRICT="test !test? ( test )"
BDEPEND="
doc? (
@@ -142,10 +146,6 @@ DEPEND="
)
"
-REQUIRED_USE="
- || ( ${IUSE_TEST_BACKENDS[*]} )
-"
-
PATCHES=(
"${FILESDIR}/${PN}-3.4.0-doc-nocompress.patch" # bug 830064
"${FILESDIR}/${PN}-3.4.0-buildstring.patch"