summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-03-22 10:48:31 -0300
committerMatt Turner <mattst88@gentoo.org>2023-03-22 10:58:23 -0400
commit402ce3e6288e3ed52a381f555a4b053c6879cb24 (patch)
tree1af1f254ac0c93542e281f68ce728c85649ef4a0 /dev-cpp/libxmlpp/libxmlpp-5.0.3.ebuild
parentdev-util/gdbus-codegen: Version bump to 2.76.1 (diff)
downloadgentoo-402ce3e6288e3ed52a381f555a4b053c6879cb24.tar.gz
gentoo-402ce3e6288e3ed52a381f555a4b053c6879cb24.tar.bz2
gentoo-402ce3e6288e3ed52a381f555a4b053c6879cb24.zip
dev-cpp/libxmlpp: Version bump to 5.0.3
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30304 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp/libxmlpp/libxmlpp-5.0.3.ebuild')
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-5.0.3.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-cpp/libxmlpp/libxmlpp-5.0.3.ebuild b/dev-cpp/libxmlpp/libxmlpp-5.0.3.ebuild
new file mode 100644
index 000000000000..49fe9c91a7cb
--- /dev/null
+++ b/dev-cpp/libxmlpp/libxmlpp-5.0.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GNOME_ORG_MODULE="${PN/pp/++}"
+
+inherit gnome2 meson
+
+DESCRIPTION="C++ wrapper for the libxml2 XML parser library"
+HOMEPAGE="http://libxmlplusplus.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="5.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/libxml2-2.7.7
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ dev-cpp/mm-common
+ app-doc/doxygen
+ media-gfx/graphviz
+ dev-libs/libxslt
+ )
+"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "/install_docdir = /s/'doc'/'gtk-doc'/" \
+ docs/reference/meson.build || die
+ sed -i \
+ -e "/install_tutorialdir = /s/'doc'/'gtk-doc'/" \
+ docs/manual/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dmaintainer-mode=false
+ -Dwarnings=min
+ -Ddist-warnings=max
+ -Dbuild-deprecated-api=true
+ $(meson_use doc build-documentation)
+ -Dvalidation=false
+ -Dbuild-pdf=false
+ -Dbuild-examples=false
+ $(meson_use test build-tests)
+ -Dmsvc14x-parallel-installable=false
+ )
+ meson_src_configure
+}