summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-20 19:24:33 -0700
committerMatt Turner <mattst88@gentoo.org>2021-05-20 19:30:26 -0700
commit831009e86e8417eb977e9e031a622b847e9e2284 (patch)
tree8197d30a096f854ee439b62e208b3e44c48729bf /dev-cpp/mm-common/mm-common-1.0.3.ebuild
parentdev-db/mysql: add bug number for failing test (diff)
downloadgentoo-831009e86e8417eb977e9e031a622b847e9e2284.tar.gz
gentoo-831009e86e8417eb977e9e031a622b847e9e2284.tar.bz2
gentoo-831009e86e8417eb977e9e031a622b847e9e2284.zip
dev-cpp/mm-common: Version bump to 1.0.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp/mm-common/mm-common-1.0.3.ebuild')
-rw-r--r--dev-cpp/mm-common/mm-common-1.0.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-cpp/mm-common/mm-common-1.0.3.ebuild b/dev-cpp/mm-common/mm-common-1.0.3.ebuild
new file mode 100644
index 000000000000..035d8e988cdb
--- /dev/null
+++ b/dev-cpp/mm-common/mm-common-1.0.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit gnome.org python-any-r1 meson
+
+DESCRIPTION="Build infrastructure and utilities for GNOME C++ bindings"
+HOMEPAGE="https://www.gtkmm.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+BDEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+
+ # Include project version in docdir name
+ sed -i -e "s:^install_docdir.*:& + '-' + meson.project_version():" meson.build || die
+}