summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-21 18:55:50 -0700
committerMatt Turner <mattst88@gentoo.org>2021-05-21 19:17:26 -0700
commit0ac6a5c48c7aa21243ea7320b40941d4d8fb65b2 (patch)
treed9826d868c836b7d7e51b7d829a840b75b71028d /dev-cpp/pangomm/pangomm-2.48.1.ebuild
parentdev-cpp/cairomm: Version bump to 1.16.1 (diff)
downloadgentoo-0ac6a5c48c7aa21243ea7320b40941d4d8fb65b2.tar.gz
gentoo-0ac6a5c48c7aa21243ea7320b40941d4d8fb65b2.tar.bz2
gentoo-0ac6a5c48c7aa21243ea7320b40941d4d8fb65b2.zip
dev-cpp/pangomm: Version bump to 2.48.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp/pangomm/pangomm-2.48.1.ebuild')
-rw-r--r--dev-cpp/pangomm/pangomm-2.48.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-cpp/pangomm/pangomm-2.48.1.ebuild b/dev-cpp/pangomm/pangomm-2.48.1.ebuild
new file mode 100644
index 000000000000..924043617bfa
--- /dev/null
+++ b/dev-cpp/pangomm/pangomm-2.48.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit gnome.org meson multilib-minimal python-any-r1
+
+DESCRIPTION="C++ interface for pango"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.48"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="doc"
+
+DEPEND="
+ >=dev-cpp/cairomm-1.16.0:1.16[doc?,${MULTILIB_USEDEP}]
+ >=dev-cpp/glibmm-2.68.0:2.68[doc?,${MULTILIB_USEDEP}]
+ >=dev-libs/libsigc++-3:3[doc?,${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.48.0[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ dev-lang/perl
+ dev-libs/libxslt
+ )
+ ${PYTHON_DEPS}
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dbuild-documentation=$(multilib_native_usex doc true false)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_test() {
+ meson_src_test
+}