summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Buchinger <cb-gentoo@guya.de>2018-10-05 13:03:01 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-10-07 19:01:48 +0200
commite82f9d8b7a2e375886466f0cf92a1a6292237035 (patch)
tree70c26f19cc7fb6e15db8ca72d9496556c2f1ff39 /dev-cpp/popl/popl-1.2.0.ebuild
parentdev-cpp/aixlog: New package (diff)
downloadgentoo-e82f9d8b7a2e375886466f0cf92a1a6292237035.tar.gz
gentoo-e82f9d8b7a2e375886466f0cf92a1a6292237035.tar.bz2
gentoo-e82f9d8b7a2e375886466f0cf92a1a6292237035.zip
dev-cpp/popl: New package
Header-only C++ program options parser library. Needed as dependency for new package media-sound/snapcast Closes: https://bugs.gentoo.org/667796 Signed-off-by: Christian Buchinger <cb-gentoo@guya.de> Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-cpp/popl/popl-1.2.0.ebuild')
-rw-r--r--dev-cpp/popl/popl-1.2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-cpp/popl/popl-1.2.0.ebuild b/dev-cpp/popl/popl-1.2.0.ebuild
new file mode 100644
index 000000000000..39652fbae851
--- /dev/null
+++ b/dev-cpp/popl/popl-1.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Header-only C++ program options parser library"
+HOMEPAGE="https://github.com/badaix/popl"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit cmake-utils git-r3
+
+ EGIT_REPO_URI="https://github.com/badaix/popl.git"
+ EGIT_BRANCH="develop"
+else
+ inherit cmake-utils
+
+ SRC_URI="https://github.com/badaix/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_EXAMPLE=OFF )
+
+ cmake-utils_src_configure
+}