summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-02-05 06:36:08 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-02-05 07:09:37 -0500
commit6bdfb5ab03bb84f2f6be6bb928673db7e3e346ac (patch)
tree3d666f40a22f2089b831e2bf009c514eda712fa9 /dev-cpp/rapidyaml
parentdev-cpp/rapidyaml: drop 0.4.1 (diff)
downloadgentoo-6bdfb5ab03bb84f2f6be6bb928673db7e3e346ac.tar.gz
gentoo-6bdfb5ab03bb84f2f6be6bb928673db7e3e346ac.tar.bz2
gentoo-6bdfb5ab03bb84f2f6be6bb928673db7e3e346ac.zip
dev-cpp/rapidyaml: bump to -std=c++17
Does not seem to be anything that requires staying on c++11. Technically the new gtest-1.13 only needs >=14 but may as well go higher with current gcc's default. Closes: https://bugs.gentoo.org/893272 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-cpp/rapidyaml')
-rw-r--r--dev-cpp/rapidyaml/rapidyaml-0.5.0.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-cpp/rapidyaml/rapidyaml-0.5.0.ebuild b/dev-cpp/rapidyaml/rapidyaml-0.5.0.ebuild
index f1c6896c181b..84cf212c458f 100644
--- a/dev-cpp/rapidyaml/rapidyaml-0.5.0.ebuild
+++ b/dev-cpp/rapidyaml/rapidyaml-0.5.0.ebuild
@@ -69,6 +69,9 @@ src_configure() {
# TODO: enable this+tests, should(?) be easier to do with >=0.5.0 but
# still need looking into (please fill a bug if need this right away)
-DRYML_BUILD_API=no
+
+ # rapidyaml sets c++11, but >=gtest-1.13 wants >=c++14 (bug #893272)
+ -DC4_CXX_STANDARD=17
)
cmake_src_configure