summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-05 20:42:31 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-08-06 00:27:41 -0400
commit031b974294c7b941f1dbfb337c854e8e3daf0e77 (patch)
tree764b29374fb632a736b043bd429a06f0f3340d5f /dev-cpp/simpleini
parentapp-emulation/vkd3d: drop 1.7.1 (diff)
downloadgentoo-031b974294c7b941f1dbfb337c854e8e3daf0e77.tar.gz
gentoo-031b974294c7b941f1dbfb337c854e8e3daf0e77.tar.bz2
gentoo-031b974294c7b941f1dbfb337c854e8e3daf0e77.zip
dev-cpp/simpleini: drop 4.19
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-cpp/simpleini')
-rw-r--r--dev-cpp/simpleini/Manifest1
-rw-r--r--dev-cpp/simpleini/simpleini-4.19.ebuild40
2 files changed, 0 insertions, 41 deletions
diff --git a/dev-cpp/simpleini/Manifest b/dev-cpp/simpleini/Manifest
index fe11c1acfa25..e850a145f63c 100644
--- a/dev-cpp/simpleini/Manifest
+++ b/dev-cpp/simpleini/Manifest
@@ -1,2 +1 @@
-DIST simpleini-4.19.tar.gz 62793 BLAKE2B f32a25743c89f954a0b1cce2cb29584d63083922b9b56d91b39412617067f7316ecb897474a7f3a4d550569a0d007e51780d3532079966a7ba72e2b89ff5a5cc SHA512 3f0f3120aca3350bab66fe1727f4d15536d933a0840a17b49203c2220fab7ace4383d856c1b77a84f4e36c9a5df0c3eb937ad729c977f84e7163d7e2cff400c5
DIST simpleini-4.20.tar.gz 64807 BLAKE2B 5179fbdc1a46b352590a20bcaafa88d905d75ef3334becc03caf11f5b8c4bd3673971d688f9ec0077af3192244b29befd217dfa4ef218594f68c917698727b72 SHA512 e2518d10d63026b0fd423cbd77372b60bc693e8ec1878a91ab05364a49b48d38d8d379247a27a8ffc5582ba19e333b10996f4bf48899c06c567ae0dea067a9e3
diff --git a/dev-cpp/simpleini/simpleini-4.19.ebuild b/dev-cpp/simpleini/simpleini-4.19.ebuild
deleted file mode 100644
index acd530cf090e..000000000000
--- a/dev-cpp/simpleini/simpleini-4.19.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="C++ library providing a simple API to read and write INI-style files"
-HOMEPAGE="https://github.com/brofield/simpleini/"
-SRC_URI="https://github.com/brofield/simpleini/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-cpp/gtest )"
-BDEPEND="test? ( virtual/pkgconfig )"
-
-src_compile() {
- if use test; then
- append-cppflags $($(tc-getPKG_CONFIG) --cflags gtest_main || die)
- append-ldflags $(test-flags-CCLD -pthread)
- append-libs $($(tc-getPKG_CONFIG) --libs gtest_main || die)
- local emakeargs=(
- {CC,CXX}="$(tc-getCXX)"
- CXXFLAGS="${CXXFLAGS}"
- CPPFLAGS="${CPPFLAGS}"
- LDFLAGS="${LDFLAGS} ${LIBS}"
- )
- emake -C tests "${emakeargs[@]}"
- fi
-}
-
-src_install() {
- # note: skipping ConvertUTF, can use -DSI_CONVERT_ICU instead if needed
- doheader SimpleIni.h
- einstalldocs
-}