summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-01-13 19:23:40 -0500
committerTim Harder <radhermit@gentoo.org>2016-01-13 19:23:40 -0500
commitab8d1137aacb3da6a225fb42e3512fcc1792f2f6 (patch)
tree3c645021a29d00acf4d15897212c2b9735bc4257 /dev-cpp/sparsehash/sparsehash-2.0.3.ebuild
parentdev-vcs/bfg: version bump to 1.12.8 (diff)
downloadgentoo-ab8d1137aacb3da6a225fb42e3512fcc1792f2f6.tar.gz
gentoo-ab8d1137aacb3da6a225fb42e3512fcc1792f2f6.tar.bz2
gentoo-ab8d1137aacb3da6a225fb42e3512fcc1792f2f6.zip
dev-cpp/sparsehash: version bump to 2.0.3
Diffstat (limited to 'dev-cpp/sparsehash/sparsehash-2.0.3.ebuild')
-rw-r--r--dev-cpp/sparsehash/sparsehash-2.0.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-cpp/sparsehash/sparsehash-2.0.3.ebuild b/dev-cpp/sparsehash/sparsehash-2.0.3.ebuild
new file mode 100644
index 000000000000..5fb17a073c6d
--- /dev/null
+++ b/dev-cpp/sparsehash/sparsehash-2.0.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="An extremely memory-efficient hash_map implementation"
+HOMEPAGE="https://github.com/sparsehash/sparsehash"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S=${WORKDIR}/${PN}-${P}
+
+src_install() {
+ default
+
+ # Installs just every piece
+ rm -rf "${ED}/usr/share/doc"
+ dohtml doc/*
+}