summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-19 02:27:29 +0000
committerSam James <sam@gentoo.org>2022-11-19 03:19:13 +0000
commitae4a95da4cdb44ac97adfc4c48d89317c315b5d1 (patch)
treebe7cc11668eb18b6b2a486780991a1b988f42eec /dev-cpp/tbb/tbb-2021.7.0-r1.ebuild
parentsys-devel/mold: add 1.7.1, drop 1.7.0 (diff)
downloadgentoo-ae4a95da4cdb44ac97adfc4c48d89317c315b5d1.tar.gz
gentoo-ae4a95da4cdb44ac97adfc4c48d89317c315b5d1.tar.bz2
gentoo-ae4a95da4cdb44ac97adfc4c48d89317c315b5d1.zip
dev-cpp/tbb: backport pthread EAGAIN patch for mold
Closes: https://bugs.gentoo.org/881161 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/tbb/tbb-2021.7.0-r1.ebuild')
-rw-r--r--dev-cpp/tbb/tbb-2021.7.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-cpp/tbb/tbb-2021.7.0-r1.ebuild b/dev-cpp/tbb/tbb-2021.7.0-r1.ebuild
new file mode 100644
index 000000000000..d88f920769a0
--- /dev/null
+++ b/dev-cpp/tbb/tbb-2021.7.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib flag-o-matic
+
+DESCRIPTION="High level abstract threading library"
+HOMEPAGE="https://www.threadingbuildingblocks.org"
+SRC_URI="https://github.com/oneapi-src/oneTBB/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/oneTBB-${PV}"
+
+LICENSE="Apache-2.0"
+# https://github.com/oneapi-src/oneTBB/blob/master/CMakeLists.txt#L53
+# libtbb<SONAME>-libtbbmalloc<SONAME>-libtbbbind<SONAME>
+SLOT="0/12.5-2.5-3.5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="!kernel_Darwin? ( sys-apps/hwloc:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2021.7.0-pthread-eagain.patch
+)
+
+src_configure() {
+ # bug #872287
+ filter-flags -D_GLIBCXX_ASSERTIONS
+ append-cppflags -U_GLIBCXX_ASSERTIONS
+
+ local mycmakeargs=(
+ -DTBB_TEST=$(usex test)
+ -DTBB_ENABLE_IPO=OFF
+ -DTBB_STRICT=OFF
+ )
+
+ cmake-multilib_src_configure
+}