summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2018-08-21 13:27:50 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-08-22 10:27:24 +0200
commitaed837ab7b08495754a947213a3e90932a81d1a4 (patch)
treef311d4fb8e3fc2c6a499d7d13454cb0cdaea422a /dev-cpp/tclap/tclap-1.2.2.ebuild
parentmedia-sound/id3ted: 1.0 version bump, EAPI-7 (diff)
downloadgentoo-aed837ab7b08495754a947213a3e90932a81d1a4.tar.gz
gentoo-aed837ab7b08495754a947213a3e90932a81d1a4.tar.bz2
gentoo-aed837ab7b08495754a947213a3e90932a81d1a4.zip
dev-cpp/tclap: version bump to 1.2.2.
Closes: https://bugs.gentoo.org/664172 Closes: https://github.com/gentoo/gentoo/pull/9652
Diffstat (limited to 'dev-cpp/tclap/tclap-1.2.2.ebuild')
-rw-r--r--dev-cpp/tclap/tclap-1.2.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-cpp/tclap/tclap-1.2.2.ebuild b/dev-cpp/tclap/tclap-1.2.2.ebuild
new file mode 100644
index 000000000000..53fcd8f85956
--- /dev/null
+++ b/dev-cpp/tclap/tclap-1.2.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple templatized C++ library for parsing command line arguments"
+HOMEPAGE="http://tclap.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~amd64-linux"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf $(use_enable doc doxygen)
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="${EPREFIX}/usr/share/doc/${PF}/html" install
+}