summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-05 03:50:40 +0100
committerSam James <sam@gentoo.org>2022-04-05 03:50:40 +0100
commitfdc95d1afdf224bb4315aa1be6508dc662e94409 (patch)
tree349b79a5c5fcce7551202031c5fc3155428b9e07 /dev-cpp
parentdev-db/mysql-super-smack: drop 1.3-r4 (diff)
downloadgentoo-fdc95d1afdf224bb4315aa1be6508dc662e94409.tar.gz
gentoo-fdc95d1afdf224bb4315aa1be6508dc662e94409.tar.bz2
gentoo-fdc95d1afdf224bb4315aa1be6508dc662e94409.zip
dev-cpp/folly: add 2022.04.04.00
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/folly/Manifest1
-rw-r--r--dev-cpp/folly/folly-2022.04.04.00.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-cpp/folly/Manifest b/dev-cpp/folly/Manifest
index 71801ebb7718..6bda12dfda8b 100644
--- a/dev-cpp/folly/Manifest
+++ b/dev-cpp/folly/Manifest
@@ -1,3 +1,4 @@
DIST folly-2022.03.14.00.tar.gz 3605018 BLAKE2B 11a58e3c23c1e1299c16821e552d500f8215d2fb2fbdee3699b8487e1073196dfc322461e7670d3968c703d84b0b526d2479bcb74005b763f195ce48f04a419d SHA512 0b3710862360788eb55dc40703e3862f57819acf217287f13ce125b56692c4e5b1de12289f02520ecca9007fa872a69e8936df0ec9260adf974a88286489a9b1
DIST folly-2022.03.21.00.tar.gz 3611725 BLAKE2B 6b0d3431810a26484b2c15a8ba4b245e720d717364a4305269b3adabaa2d005466dfd7ad086b38cb06ee2a2d5908e903e68486aadc62834a32b4fe59cd313095 SHA512 4e0fda55f007179883af30024fe1d389642159b1b4c915f7ef1a3c1003c8c52e2370f53ffa79d5fa75533d33becfb946d2bcbb2abdc62b9a297f977403d13dd7
DIST folly-2022.03.28.00.tar.gz 3616507 BLAKE2B da003701abe599f20ac87a2785fe9a4cd4a8896d182737eb1eac6384f3d75a792225b426febea7cc4ea99aac1a1f31eb7330e0a297f43ae7d5aafccd93784560 SHA512 6eee07b3e82247c3c8672442503e9a69a1c4607604269fc0760e11a2d0e5595029e6995fbe7c970d2052a7f228f6b92112630e6d5c624369fc52e5ad1823ef74
+DIST folly-2022.04.04.00.tar.gz 3629241 BLAKE2B 6e606c7412a8c2dcf731bf1373d3ed33680b07641109fd5da066bd648961d9608d82496322496bf6334a8576ae2394a36603ba8098e972c9b949a989f04baa4f SHA512 923cab43820b75ef7f614a3e62d278ecb3a64beeabefee64d6fb113fbbfd368b69a2a90015706ba58e68967eb9bbf97052678edd1f2d6d4d466792f08e547488
diff --git a/dev-cpp/folly/folly-2022.04.04.00.ebuild b/dev-cpp/folly/folly-2022.04.04.00.ebuild
new file mode 100644
index 000000000000..b644181fecc6
--- /dev/null
+++ b/dev-cpp/folly/folly-2022.04.04.00.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="An open-source C++ library developed and used at Facebook"
+HOMEPAGE="https://github.com/facebook/folly"
+SRC_URI="https://github.com/facebook/folly/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="llvm-libunwind test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-arch/bzip2
+ app-arch/lz4:=
+ app-arch/snappy:=
+ app-arch/xz-utils
+ app-arch/zstd:=
+ dev-cpp/gflags:=
+ dev-cpp/glog[gflags]
+ dev-libs/boost:=[context,threads(+)]
+ dev-libs/double-conversion:=
+ dev-libs/libaio
+ dev-libs/libevent:=
+ dev-libs/libfmt:=
+ dev-libs/libsodium:=
+ dev-libs/openssl:=
+ sys-libs/liburing:=
+ sys-libs/zlib
+ llvm-libunwind? ( sys-libs/llvm-libunwind:= )
+ !llvm-libunwind? ( sys-libs/libunwind:= )"
+# libiberty is linked statically
+DEPEND="${RDEPEND}
+ sys-libs/binutils-libs"
+BDEPEND="test? ( sys-devel/clang )"
+
+pkg_setup() {
+ if use test && [[ ${BUILD_TYPE} != "binary" ]] && ! tc-is-clang ; then
+ ewarn "Forcing build with Clang due to GCC bug (because tests are enabled)"
+ ewarn "(https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104008)"
+
+ export CC=${CHOST}-clang
+ export CXX=${CHOST}-clang++
+ fi
+}
+
+src_configure() {
+ # TODO: liburing could in theory be optional but fails to link
+
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+
+ -DBUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}