summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/go-etcd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/go-etcd')
-rw-r--r--dev-db/go-etcd/Manifest2
-rw-r--r--dev-db/go-etcd/go-etcd-0_p20141013-r1.ebuild43
-rw-r--r--dev-db/go-etcd/go-etcd-2.0.0-r1.ebuild43
-rw-r--r--dev-db/go-etcd/go-etcd-2.0.0.ebuild43
-rw-r--r--dev-db/go-etcd/metadata.xml13
5 files changed, 144 insertions, 0 deletions
diff --git a/dev-db/go-etcd/Manifest b/dev-db/go-etcd/Manifest
new file mode 100644
index 000000000000..f33f5b54a665
--- /dev/null
+++ b/dev-db/go-etcd/Manifest
@@ -0,0 +1,2 @@
+DIST go-etcd-0_p20141013.tar.gz 18214 SHA256 1f23919939588fbdc76dc40977f20d47fe67e633be24f53e4042122a942f867e SHA512 af07b2434bbad219962e989ca1d6ccb86bb40f698aa3f2b681ac04094dc7e878593af6a54e9c1e976d1aeb451661d8100295b0637291b46bafa45452537f1575 WHIRLPOOL 6cfb874e90bc43d643eb9b3db59e9d7c914614adfcb34db642b794c645823863cdab70c72b0e60abda2dc97dc1c526bc2d8c4c28d7c32811fcc9798744b4beaa
+DIST go-etcd-2.0.0.tar.gz 18214 SHA256 1f23919939588fbdc76dc40977f20d47fe67e633be24f53e4042122a942f867e SHA512 af07b2434bbad219962e989ca1d6ccb86bb40f698aa3f2b681ac04094dc7e878593af6a54e9c1e976d1aeb451661d8100295b0637291b46bafa45452537f1575 WHIRLPOOL 6cfb874e90bc43d643eb9b3db59e9d7c914614adfcb34db642b794c645823863cdab70c72b0e60abda2dc97dc1c526bc2d8c4c28d7c32811fcc9798744b4beaa
diff --git a/dev-db/go-etcd/go-etcd-0_p20141013-r1.ebuild b/dev-db/go-etcd/go-etcd-0_p20141013-r1.ebuild
new file mode 100644
index 000000000000..8ea0f6d7fd64
--- /dev/null
+++ b/dev-db/go-etcd/go-etcd-0_p20141013-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+DESCRIPTION="Go client library for etcd"
+GO_PN=github.com/coreos/${PN}
+HOMEPAGE="https://${GO_PN}"
+EGIT_COMMIT="25e2c63be8e8ab405014a78879e0992ae5ff55e8"
+SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-lang/go-1.4"
+RDEPEND=""
+S=${WORKDIR}
+
+src_unpack() {
+ default_src_unpack
+ mkdir -p src/${GO_PN%/*} || die
+ mv ${PN}-${EGIT_COMMIT} src/${GO_PN} || die
+}
+
+src_compile() {
+ # Create a filtered GOROOT tree out of symlinks,
+ # excluding go-etcd, for bug #503324.
+ cp -sR /usr/lib/go goroot || die
+ rm -rf goroot/src/${GO_PN} || die
+ rm -rf goroot/pkg/linux_${ARCH}/${GO_PN} || die
+ GOROOT=${WORKDIR}/goroot GOPATH=${WORKDIR} \
+ go install -x ${GO_PN}/etcd || die
+}
+
+src_install() {
+ insopts -m0644 -p # preserve timestamps for bug 551486
+ insinto /usr/lib/go
+ doins -r pkg
+ insinto /usr/lib/go/src
+ find src/${GO_PN} -name .gitignore -delete
+ doins -r src/*
+}
diff --git a/dev-db/go-etcd/go-etcd-2.0.0-r1.ebuild b/dev-db/go-etcd/go-etcd-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..79358b57b672
--- /dev/null
+++ b/dev-db/go-etcd/go-etcd-2.0.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+DESCRIPTION="Go client library for etcd"
+GO_PN=github.com/coreos/${PN}
+HOMEPAGE="https://${GO_PN}"
+EGIT_COMMIT="25e2c63be8e8ab405014a78879e0992ae5ff55e8"
+SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-lang/go-1.4:="
+RDEPEND=""
+S=${WORKDIR}
+
+src_unpack() {
+ default_src_unpack
+ mkdir -p src/${GO_PN%/*} || die
+ mv ${PN}-${EGIT_COMMIT} src/${GO_PN} || die
+}
+
+src_compile() {
+ # Create a filtered GOROOT tree out of symlinks,
+ # excluding go-etcd, for bug #503324.
+ cp -sR /usr/lib/go goroot || die
+ rm -rf goroot/src/${GO_PN} || die
+ rm -rf goroot/pkg/linux_${ARCH}/${GO_PN} || die
+ GOROOT=${WORKDIR}/goroot GOPATH=${WORKDIR} \
+ go install -x ${GO_PN}/etcd || die
+}
+
+src_install() {
+ insopts -m0644 -p # preserve timestamps for bug 551486
+ insinto /usr/lib/go
+ doins -r pkg
+ insinto /usr/lib/go/src
+ find src/${GO_PN} -name .gitignore -delete
+ doins -r src/*
+}
diff --git a/dev-db/go-etcd/go-etcd-2.0.0.ebuild b/dev-db/go-etcd/go-etcd-2.0.0.ebuild
new file mode 100644
index 000000000000..8ea0f6d7fd64
--- /dev/null
+++ b/dev-db/go-etcd/go-etcd-2.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+DESCRIPTION="Go client library for etcd"
+GO_PN=github.com/coreos/${PN}
+HOMEPAGE="https://${GO_PN}"
+EGIT_COMMIT="25e2c63be8e8ab405014a78879e0992ae5ff55e8"
+SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-lang/go-1.4"
+RDEPEND=""
+S=${WORKDIR}
+
+src_unpack() {
+ default_src_unpack
+ mkdir -p src/${GO_PN%/*} || die
+ mv ${PN}-${EGIT_COMMIT} src/${GO_PN} || die
+}
+
+src_compile() {
+ # Create a filtered GOROOT tree out of symlinks,
+ # excluding go-etcd, for bug #503324.
+ cp -sR /usr/lib/go goroot || die
+ rm -rf goroot/src/${GO_PN} || die
+ rm -rf goroot/pkg/linux_${ARCH}/${GO_PN} || die
+ GOROOT=${WORKDIR}/goroot GOPATH=${WORKDIR} \
+ go install -x ${GO_PN}/etcd || die
+}
+
+src_install() {
+ insopts -m0644 -p # preserve timestamps for bug 551486
+ insinto /usr/lib/go
+ doins -r pkg
+ insinto /usr/lib/go/src
+ find src/${GO_PN} -name .gitignore -delete
+ doins -r src/*
+}
diff --git a/dev-db/go-etcd/metadata.xml b/dev-db/go-etcd/metadata.xml
new file mode 100644
index 000000000000..2d6fe69da263
--- /dev/null
+++ b/dev-db/go-etcd/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <bugs-to>https://github.com/coreos/go-etcd/issues</bugs-to>
+ <changelog>https://github.com/coreos/go-etcd/commits/master</changelog>
+ <doc>https://godoc.org/github.com/coreos/go-etcd/etcd</doc>
+ <remote-id type="github">coreos/go-etcd</remote-id>
+ </upstream>
+ <maintainer>
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>