summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2024-05-15 21:48:45 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-06-28 10:43:34 +0300
commit7e70db136f5db46c0fad20e55550254ed2cfe30e (patch)
treee6081b2ca0dac36557be718645af33b90f3826f0 /dev-db/litecli
parentdev-db/postgresql: add 17_beta2, drop 17_beta1 (diff)
downloadgentoo-7e70db136f5db46c0fad20e55550254ed2cfe30e.tar.gz
gentoo-7e70db136f5db46c0fad20e55550254ed2cfe30e.tar.bz2
gentoo-7e70db136f5db46c0fad20e55550254ed2cfe30e.zip
dev-db/litecli: add 1.11.0
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/36688 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-db/litecli')
-rw-r--r--dev-db/litecli/Manifest1
-rw-r--r--dev-db/litecli/litecli-1.11.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-db/litecli/Manifest b/dev-db/litecli/Manifest
index a0467c888fe4..26832ab84246 100644
--- a/dev-db/litecli/Manifest
+++ b/dev-db/litecli/Manifest
@@ -1,2 +1,3 @@
DIST litecli-1.10.0.tar.gz 887727 BLAKE2B 141a13760ce24530a72d2a1fb1c896378f1f35a9354b8a6b553792607337b2ea861481f995f1ff016ac4fca1c7bde1aada4c193acd388fdf03095900b137c303 SHA512 aa497fe050f4e1135f2c63f4c0cbab736400158c546a0391f3eca956b38132349ad2eb46505beb52651f74bc5ff1a2ba9b0254e7a6a86d79e461fdd0508fb412
DIST litecli-1.10.1.tar.gz 887832 BLAKE2B 304feead856a148726f729abd46d91fb2d0bbf7d99e05d437814c0e254f7e957f132317194e01e4dd62ddcdd2dda15c1fcba71c3086f286dd6aeb4aefe419f64 SHA512 f53c04a101f8abe52e81450309b6eab766742b0d26900608024ac8112efdc959787ea3c5997e9647529f65a17544ee31cc70f14b503a9ad3566d545568d822dd
+DIST litecli-1.11.0.tar.gz 887986 BLAKE2B 4f445a0d29152998ab0e27ec814f1f46af44db949c817a50e7be8af659525f13113c4a831a8bf4f31a21c7922d93e12c792e8aa44b1e8480619418aeaa72aa89 SHA512 31a97d412d5749b6e8d32b88d8b41fde79d8ca9657da9885f39dc92cb0ad00ac6ab98f931ab57806be05ba9249580f1ea5ff25849d86c2f044dc40f437b6a52e
diff --git a/dev-db/litecli/litecli-1.11.0.ebuild b/dev-db/litecli/litecli-1.11.0.ebuild
new file mode 100644
index 000000000000..ae7764cb1ede
--- /dev/null
+++ b/dev-db/litecli/litecli-1.11.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1
+
+DESCRIPTION="CLI for SQLite with auto-completion and syntax highlighting"
+HOMEPAGE="https://litecli.com/ https://github.com/dbcli/litecli"
+SRC_URI="https://github.com/dbcli/litecli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/cli-helpers-2.2.1[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/prompt-toolkit-3.0.3[${PYTHON_USEDEP}]
+ <dev-python/prompt-toolkit-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pygments-1.5[${PYTHON_USEDEP}]
+ dev-python/sqlparse[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest