summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2017-07-06 08:50:17 +0300
committerSergey Popov <pinkbyte@gentoo.org>2017-07-06 08:50:17 +0300
commit1eafe6c506a7790ef6a0be14dd7f2bc57339d404 (patch)
treef608f73a73e593baefd32abc50df9c299319b510 /dev-db/sqlcipher/sqlcipher-3.4.0.ebuild
parentdev-db/sqlcipher-3.4.1: stable on amd64 and x86 (diff)
downloadgentoo-1eafe6c506a7790ef6a0be14dd7f2bc57339d404.tar.gz
gentoo-1eafe6c506a7790ef6a0be14dd7f2bc57339d404.tar.bz2
gentoo-1eafe6c506a7790ef6a0be14dd7f2bc57339d404.zip
dev-db/sqlcipher: drop old versions
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'dev-db/sqlcipher/sqlcipher-3.4.0.ebuild')
-rw-r--r--dev-db/sqlcipher/sqlcipher-3.4.0.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-db/sqlcipher/sqlcipher-3.4.0.ebuild b/dev-db/sqlcipher/sqlcipher-3.4.0.ebuild
deleted file mode 100644
index fdf576470c1d..000000000000
--- a/dev-db/sqlcipher/sqlcipher-3.4.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools eutils flag-o-matic multilib-minimal
-
-DESCRIPTION="Full Database Encryption for SQLite"
-HOMEPAGE="https://www.zetetic.net/sqlcipher/"
-SRC_URI="https://github.com/sqlcipher/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="readline libressl static-libs tcl test"
-
-# Tcl is always needed by buildsystem
-RDEPEND="
- !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
- readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
- tcl? ( dev-lang/tcl:=[${MULTILIB_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- dev-lang/tcl:*"
-
-# Testsuite requires compilation with TCL, bug #582584
-REQUIRED_USE="test? ( tcl )"
-
-DOCS=( README.md )
-
-src_prepare() {
- append-cflags -DSQLITE_HAS_CODEC
-
- eapply_user
- eautoreconf
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- econf \
- --enable-fts3 \
- --enable-fts4 \
- --enable-fts5 \
- --enable-json1 \
- --enable-tempstore \
- $(use_enable readline) \
- $(use_enable static-libs static) \
- $(use_enable tcl)
-}
-
-multilib_src_install_all() {
- prune_libtool_files
-}