summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2023-01-09 08:37:30 +0000
committerPatrick Lauer <patrick@gentoo.org>2023-01-09 08:37:39 +0000
commita9c1311337e7a346887ff327ada0c6fbaa2e6ae6 (patch)
treee98e15c09f7c78f5cae0a95ccea993b9ee708000 /dev-db/timescaledb
parentapp-text/zathura-pdf-mupdf-9999: update live build (diff)
downloadgentoo-a9c1311337e7a346887ff327ada0c6fbaa2e6ae6.tar.gz
gentoo-a9c1311337e7a346887ff327ada0c6fbaa2e6ae6.tar.bz2
gentoo-a9c1311337e7a346887ff327ada0c6fbaa2e6ae6.zip
dev-db/timescaledb: add 2.9.1
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db/timescaledb')
-rw-r--r--dev-db/timescaledb/Manifest1
-rw-r--r--dev-db/timescaledb/timescaledb-2.9.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-db/timescaledb/Manifest b/dev-db/timescaledb/Manifest
index be96051fc28c..d973a6b4d1ce 100644
--- a/dev-db/timescaledb/Manifest
+++ b/dev-db/timescaledb/Manifest
@@ -2,3 +2,4 @@ DIST timescaledb-2.7.2.tar.gz 2990906 BLAKE2B 48ed3ad549e331d0f134ba3ecdb7ffe97e
DIST timescaledb-2.8.0.tar.gz 6768327 BLAKE2B cc6895f4389c1a0b04bf492432325212b0ee8bd4b2a6c3c8ba1abbd36bd5ae9ec4a95e520100d87ba0f787fb25c0b98dd42667330b3ba9d72d06e36dc66c0426 SHA512 0d9c947b230b2aecfa8d6bc8c0a995fe2847e8851fff58d5fcfab532cf54581f72acd2c9eaa8e55bd5e425db5c31baa4bef83ccd41413a26ce0a9c940d2ab6db
DIST timescaledb-2.8.1.tar.gz 6789998 BLAKE2B 63684a5e18bf6104700bb0d78f5fb16bad35627160e1b96f1688b6b1065da9fd03377d5e56e4832da2e04879bbf416d31587bcc27e9b5a01b635a963515f60ef SHA512 69dfea5874d5c1ca8fef1382b8fc49d709a09908009fe38fe4ae44bebdae701615e3cbeb2f3ecd2044babd1a7c6ff255f96fa31f94f84293cfba942542775c54
DIST timescaledb-2.9.0.tar.gz 7340009 BLAKE2B b7eb3bb5f866b09ff8c78c4430fa570dd491336428cb74f4d9f961a7f0432dde5dcef58533acdc9541f8c49e93a6d62af4e37762b73de334437276c8e9a39f80 SHA512 7dd7a3d8cc3f3d6480b411c6254e055a723c48c5312a349d4f6e35932798cf8413f77c8b51fb193bdcdc8eee2b3eca970df1fd0a4fa160e3ad433f86e55dc7c7
+DIST timescaledb-2.9.1.tar.gz 7338112 BLAKE2B 83d0c6fab142de4b7e25ba75c3851e4cec794b3e2b79cbd2e44e15f19311913cf3112728797b2ef5fc282122160c3e5e19d01338da260892a9c1d71a53008414 SHA512 2f8c374517ede11cd65c7e281b2318604734508d7e4d12d447d13c7df6e77fa15a1c5580b64a28d57b94cebb95cf220c1a9d69fb1c3e0f044aab142232ebf61a
diff --git a/dev-db/timescaledb/timescaledb-2.9.1.ebuild b/dev-db/timescaledb/timescaledb-2.9.1.ebuild
new file mode 100644
index 000000000000..83f98f57647b
--- /dev/null
+++ b/dev-db/timescaledb/timescaledb-2.9.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 12 13 14 15 )
+POSTGRES_USEDEP="ssl"
+
+inherit postgres-multi cmake
+
+DESCRIPTION="Open-source time-series SQL database"
+HOMEPAGE="https://www.timescale.com/"
+SRC_URI="https://github.com/timescale/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE="proprietary-extensions"
+LICENSE="POSTGRESQL Apache-2.0 proprietary-extensions? ( timescale )"
+
+KEYWORDS="~amd64"
+
+SLOT=0
+
+RESTRICT="test"
+
+DEPEND="${POSTGRES_DEP}"
+RDEPEND="${DEPEND}"
+
+CMAKE_IN_SOURCE_BUILD=yes
+CMAKE_BUILD_TYPE="RelWithDebInfo"
+BUILD_DIR=${WORKDIR}/${P}
+
+src_prepare() {
+ postgres-multi_src_prepare
+ postgres-multi_foreach cmake_src_prepare
+}
+
+timescale_configure() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ local mycmakeargs=( "-DPG_CONFIG=/usr/bin/pg_config${MULTIBUILD_VARIANT}" "-DREGRESS_CHECKS=OFF" )
+
+ # licensing is tied to features, this useflag disables the non-apache2 licensed bits
+ if ! use proprietary-extensions ; then
+ mycmakeargs+=("-DAPACHE_ONLY=ON")
+ fi
+ cmake_src_configure
+}
+
+src_configure() {
+ postgres-multi_foreach timescale_configure
+}
+
+timescale_src_compile() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_compile
+}
+
+src_compile() {
+ postgres-multi_foreach timescale_src_compile
+}
+
+timescale_src_install() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_install
+}
+
+src_install() {
+ postgres-multi_foreach timescale_src_install
+}