summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-02-01 10:36:36 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-02-01 11:10:13 +0100
commitc8947d11000a15ab7d438b5ad5c44dc4747129c4 (patch)
tree85b1ebd5a00db38056faa12c91d73fa6edba1db7 /dev-dotnet/dotnet-sdk-bin
parentsci-misc/jupyterlab-desktop-bin: add 4.0.12.1 (diff)
downloadgentoo-c8947d11000a15ab7d438b5ad5c44dc4747129c4.tar.gz
gentoo-c8947d11000a15ab7d438b5ad5c44dc4747129c4.tar.bz2
gentoo-c8947d11000a15ab7d438b5ad5c44dc4747129c4.zip
dev-dotnet/dotnet-sdk-bin: do not strip the dotnet binary
Closes: https://bugs.gentoo.org/923430 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-dotnet/dotnet-sdk-bin')
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.417-r3.ebuild (renamed from dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.417-r2.ebuild)4
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r3.ebuild (renamed from dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r2.ebuild)4
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.100-r3.ebuild (renamed from dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.100-r2.ebuild)4
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.101-r2.ebuild (renamed from dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.101-r1.ebuild)4
4 files changed, 16 insertions, 0 deletions
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.417-r2.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.417-r3.ebuild
index ff4d8c61be4f..11eef21196e3 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.417-r2.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.417-r3.ebuild
@@ -131,6 +131,10 @@ src_install() {
fperms 0755 "/${dest}"
dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SDK_SLOT}"
+
+ # STRIP="llvm-strip" corrupts some executables when using the patchelf hack,
+ # bug https://bugs.gentoo.org/923430
+ dostrip -x "/${dest}/dotnet"
}
pkg_postinst() {
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r2.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r3.ebuild
index ef7d6fbccea9..fec8f0f1835d 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r2.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r3.ebuild
@@ -132,6 +132,10 @@ src_install() {
fperms 0755 "/${dest}"
dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SDK_SLOT}"
+
+ # STRIP="llvm-strip" corrupts some executables when using the patchelf hack,
+ # bug https://bugs.gentoo.org/923430
+ dostrip -x "/${dest}/dotnet"
}
pkg_postinst() {
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.100-r2.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.100-r3.ebuild
index 4b12b99a8b28..e2e720b4af62 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.100-r2.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.100-r3.ebuild
@@ -133,6 +133,10 @@ src_install() {
fperms 0755 "/${dest}"
dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SDK_SLOT}"
+
+ # STRIP="llvm-strip" corrupts some executables when using the patchelf hack,
+ # bug https://bugs.gentoo.org/923430
+ dostrip -x "/${dest}/dotnet"
}
pkg_postinst() {
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.101-r1.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.101-r2.ebuild
index b00890c77647..b4bdad035971 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.101-r1.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.101-r2.ebuild
@@ -133,6 +133,10 @@ src_install() {
fperms 0755 "/${dest}"
dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SDK_SLOT}"
+
+ # STRIP="llvm-strip" corrupts some executables when using the patchelf hack,
+ # bug https://bugs.gentoo.org/923430
+ dostrip -x "/${dest}/dotnet"
}
pkg_postinst() {