summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-dotnet/log4net
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-dotnet/log4net')
-rw-r--r--dev-dotnet/log4net/Manifest2
-rw-r--r--dev-dotnet/log4net/files/log4net.pc.in-r18
-rw-r--r--dev-dotnet/log4net/log4net-1.2.11.ebuild45
-rw-r--r--dev-dotnet/log4net/metadata.xml5
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-dotnet/log4net/Manifest b/dev-dotnet/log4net/Manifest
new file mode 100644
index 000000000000..d0237770d4f7
--- /dev/null
+++ b/dev-dotnet/log4net/Manifest
@@ -0,0 +1,2 @@
+DIST log4net-1.2.11-src.zip 1208854 SHA256 d9926e32e2b18a67ef4f90553b560621d34c49e6eb53b1f4d954b6bf6501e771 SHA512 b6ad8c873de69a30c68c82265dd2a5de331ecb780896f750088fe1e91f17191c2b54850629ece26659ec4c72b695cccae48eae30dbdf4dd18d5545cc24a42865 WHIRLPOOL d2c0c3e1c4d59c0c94b395d4055ad7ab1a0b84966aeb1f8f89396c1f74c8e11aa55bf448fec5915e3e7d91093c30e740285a615c462b4e9de1cc5e5a2d87aba8
+DIST log4net.snk 596 SHA256 6d593f81f9557e206d9f822cc2b0a07bd28a7e6a6448e8eed4b619812950db69 SHA512 b0525adfe90b8d86c7e7ac8295097b60b03b427aa4e6ad36b32bb98c7bc9fc081158249285c42eeff7637bd66a742ca422906a85544ca6526fe5e785cead8ff7 WHIRLPOOL 342123baa0ed762c67e7e14d9dd5b9f1cdea477fed9061bce7ee446916dda804f44e00f5647cd65649ca605ff4fd414dc3dd53f2705ca20db5594923f74348f7
diff --git a/dev-dotnet/log4net/files/log4net.pc.in-r1 b/dev-dotnet/log4net/files/log4net.pc.in-r1
new file mode 100644
index 000000000000..262850fc1e4d
--- /dev/null
+++ b/dev-dotnet/log4net/files/log4net.pc.in-r1
@@ -0,0 +1,8 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${exec_prefix}/@LIBDIR@
+
+Name: Log4net
+Description: Log4net - Logging library for C# and VB.NET
+Version: @VERSION@
+Libs: -r:${libdir}/mono/log4net/log4net.dll
diff --git a/dev-dotnet/log4net/log4net-1.2.11.ebuild b/dev-dotnet/log4net/log4net-1.2.11.ebuild
new file mode 100644
index 000000000000..3a28feb4d9ad
--- /dev/null
+++ b/dev-dotnet/log4net/log4net-1.2.11.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils mono multilib versionator
+
+PV_MAJOR=$(get_version_component_range 1-2)
+
+DESCRIPTION="tool to help the programmer output log statements to a variety of output targets"
+HOMEPAGE="http://logging.apache.org/log4net/"
+SRC_URI="mirror://apache/logging/log4net/source/${P}-src.zip
+ http://dev.gentoo.org/~pacho/dotnet/log4net.snk"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/mono-2.0"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ /usr/bin/gmcs \
+ -t:library \
+ -out:log4net.dll \
+ -keyfile:"${DISTDIR}"/log4net.snk \
+ -r:System.Data \
+ -r:System.Web \
+ $(find src -name "*.cs") || die
+}
+
+src_install() {
+ egacinstall log4net.dll
+ dodir /usr/$(get_libdir)/pkgconfig
+ sed -e "s:@VERSION@:${PV}:" \
+ -e "s:@LIBDIR@:$(get_libdir):" \
+ -e "s:@NET_VERSION@:2.0:" \
+ "${FILESDIR}"/${PN}.pc.in-r1 > "${D}"/usr/$(get_libdir)/pkgconfig/${PN}-${PV}.pc
+ dosym ${PN}-${PV}.pc /usr/$(get_libdir)/pkgconfig/${PN}-${PV_MAJOR}.pc
+ dosym ${PN}-${PV}.pc /usr/$(get_libdir)/pkgconfig/${PN}.pc
+
+ dodoc README.txt STATUS.txt
+}
diff --git a/dev-dotnet/log4net/metadata.xml b/dev-dotnet/log4net/metadata.xml
new file mode 100644
index 000000000000..e85974a7fa17
--- /dev/null
+++ b/dev-dotnet/log4net/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dotnet</herd>
+</pkgmetadata>