summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-12-28 16:58:55 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-12-28 17:04:48 +0100
commit38a2eeaa480e1c0c0b908605e6722c0949413bf0 (patch)
tree048ce0ebb0ea42c27be1574772429008f9a329e8 /dev-dotnet
parentdev-vcs/sourcegit: drop old 8.39 (diff)
downloadgentoo-38a2eeaa480e1c0c0b908605e6722c0949413bf0.tar.gz
gentoo-38a2eeaa480e1c0c0b908605e6722c0949413bf0.tar.bz2
gentoo-38a2eeaa480e1c0c0b908605e6722c0949413bf0.zip
dev-dotnet/coco: update DOTNET_PKG_COMPAT to .NET 9.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/coco/coco-2014.12.24-r4.ebuild37
-rw-r--r--dev-dotnet/coco/files/coco-2014.12.24-Coco-csproj-net9.patch11
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-dotnet/coco/coco-2014.12.24-r4.ebuild b/dev-dotnet/coco/coco-2014.12.24-r4.ebuild
new file mode 100644
index 000000000000..d0c87d1f9f99
--- /dev/null
+++ b/dev-dotnet/coco/coco-2014.12.24-r4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOTNET_PKG_COMPAT="9.0"
+NUGET_PACKAGES=""
+
+inherit dotnet-pkg
+
+DESCRIPTION="The compiler generator Coco/R for C#"
+HOMEPAGE="https://github.com/boogie-org/coco/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/boogie-org/${PN}.git"
+else
+ SRC_URI="https://github.com/boogie-org/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DOTNET_PKG_PROJECTS=( Coco.csproj )
+PATCHES=( "${FILESDIR}/coco-2014.12.24-Coco-csproj-net9.patch" )
+
+src_unpack() {
+ dotnet-pkg_src_unpack
+
+ if [[ -n "${EGIT_REPO_URI}" ]] ; then
+ git-r3_src_unpack
+ fi
+}
diff --git a/dev-dotnet/coco/files/coco-2014.12.24-Coco-csproj-net9.patch b/dev-dotnet/coco/files/coco-2014.12.24-Coco-csproj-net9.patch
new file mode 100644
index 000000000000..553c1ab0b011
--- /dev/null
+++ b/dev-dotnet/coco/files/coco-2014.12.24-Coco-csproj-net9.patch
@@ -0,0 +1,11 @@
+--- a/Coco.csproj
++++ b/Coco.csproj
+@@ -13,7 +13,7 @@
+
+ <PropertyGroup>
+ <OutputType>Exe</OutputType>
+- <TargetFrameworks>net6.0;net5.0;netcoreapp3.1</TargetFrameworks>
++ <TargetFrameworks>net9.0</TargetFrameworks>
+ <PackAsTool>true</PackAsTool>
+ <ToolCommandName>coco</ToolCommandName>
+ <GeneratePackageOnBuild>true</GeneratePackageOnBuild>