summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-24 00:38:39 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-24 00:38:50 +0100
commit5113fc7c5d5620e25f6253bec25495613dfaaedc (patch)
treec09f2f09d617407f5c06986d8760754139dcb7fd /dev-embedded/lpc21isp
parentapp-text/tkman: update EAPI 5 -> 8 (diff)
downloadgentoo-5113fc7c5d5620e25f6253bec25495613dfaaedc.tar.gz
gentoo-5113fc7c5d5620e25f6253bec25495613dfaaedc.tar.bz2
gentoo-5113fc7c5d5620e25f6253bec25495613dfaaedc.zip
dev-embedded/lpc21isp: add 1.97, drop 1.85
EAPI 5 -> 8 + fix hard-coded CC=gcc assignment. Closes: https://bugs.gentoo.org/722604 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-embedded/lpc21isp')
-rw-r--r--dev-embedded/lpc21isp/Manifest2
-rw-r--r--dev-embedded/lpc21isp/files/lpc21isp-1.97-makefile-tc-vars.patch11
-rw-r--r--dev-embedded/lpc21isp/lpc21isp-1.97.ebuild (renamed from dev-embedded/lpc21isp/lpc21isp-1.85.ebuild)20
3 files changed, 21 insertions, 12 deletions
diff --git a/dev-embedded/lpc21isp/Manifest b/dev-embedded/lpc21isp/Manifest
index 93f2bf182722..675d272fbf03 100644
--- a/dev-embedded/lpc21isp/Manifest
+++ b/dev-embedded/lpc21isp/Manifest
@@ -1 +1 @@
-DIST lpc21isp_185.tar.gz 54735 BLAKE2B 0ba04fca994891ccd68a2d6b6c981bb6e2cf91a70eaa2ba576eccaad328591665b53ad551d349a59c7b86e2636504c09276a16f3f5a34953d643b4f1fa4628ff SHA512 585c8f02771fc68719c8a5e6cc4253854dce4f4e0047df8a1d57db273cb51c9d4fcbe1066b079aaec54d7ca189e90710647b95fdb320729753967c265b1ac954
+DIST lpc21isp-1.97.tar.gz 62171 BLAKE2B 0c01e35c4006f6b106651629f82a025fa15810e0b809adc8d672d1e8a8bde0e81b897bfd2fab88b770ac5527ded537567c1e8b3eb16f938752c56779f5435aa3 SHA512 bd4644352b9d4f3c24f93d8fe68274e2d238d9c91d3d0d6a0c06b878d31099cada772b35ce94885bccd309f5e2e56bc881a0a5302901349046a51537cfebb795
diff --git a/dev-embedded/lpc21isp/files/lpc21isp-1.97-makefile-tc-vars.patch b/dev-embedded/lpc21isp/files/lpc21isp-1.97-makefile-tc-vars.patch
new file mode 100644
index 000000000000..18e6d21fe19c
--- /dev/null
+++ b/dev-embedded/lpc21isp/files/lpc21isp-1.97-makefile-tc-vars.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ all: lpc21isp
+
+ GLOBAL_DEP = adprog.h lpc21isp.h lpcprog.h lpcterm.h
+-CC = gcc
++CC ?= gcc
+
+ ifneq ($(findstring(freebsd, $(OSTYPE))),)
+ CFLAGS+=-D__FREEBSD__
diff --git a/dev-embedded/lpc21isp/lpc21isp-1.85.ebuild b/dev-embedded/lpc21isp/lpc21isp-1.97.ebuild
index fd08a385c1e2..5c201608ac52 100644
--- a/dev-embedded/lpc21isp/lpc21isp-1.85.ebuild
+++ b/dev-embedded/lpc21isp/lpc21isp-1.97.ebuild
@@ -1,25 +1,23 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit versionator
-
-MY_PN="${PN}_$(delete_all_version_separators)"
+MY_P="${PN}_$(ver_rs 1- '')"
DESCRIPTION="In-circuit programming (ISP) tool for the NXP microcontrollers"
HOMEPAGE="https://sourceforge.net/projects/lpc21isp/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}.tar.gz"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
-LICENSE="LGPL-3"
+LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND=""
-RDEPEND=""
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.97-makefile-tc-vars.patch
+)
-S=${WORKDIR}
+S="${WORKDIR}"/${MY_P}
src_install() {
dobin lpc21isp