summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2023-10-08 09:56:39 +0100
committerMatthew Smith <matthew@gentoo.org>2023-10-08 10:43:36 +0100
commit0bf72d399473ff66a5d4163dd18051b4693070ca (patch)
tree868fd3321a4fb4f12c9438ea2a530caea8c0f7b9 /dev-embedded/picotool/picotool-1.1.2.ebuild
parentmedia-sound/ardour: added dependency on net-libs/libwebsockets (diff)
downloadgentoo-0bf72d399473ff66a5d4163dd18051b4693070ca.tar.gz
gentoo-0bf72d399473ff66a5d4163dd18051b4693070ca.tar.bz2
gentoo-0bf72d399473ff66a5d4163dd18051b4693070ca.zip
dev-embedded/picotool: add 1.1.2
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'dev-embedded/picotool/picotool-1.1.2.ebuild')
-rw-r--r--dev-embedded/picotool/picotool-1.1.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-embedded/picotool/picotool-1.1.2.ebuild b/dev-embedded/picotool/picotool-1.1.2.ebuild
new file mode 100644
index 000000000000..46993520bd90
--- /dev/null
+++ b/dev-embedded/picotool/picotool-1.1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+SDK_PV=1.4.0
+SDK_PN=pico-sdk
+SDK_P=${SDK_PN}-${SDK_PV}
+
+DESCRIPTION="tool for interacting with rp2040 devices and binaries"
+HOMEPAGE="https://github.com/raspberrypi/picotool"
+SRC_URI="
+ https://github.com/raspberrypi/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/raspberrypi/${SDK_PN}/archive/refs/tags/${SDK_PV}.tar.gz -> ${SDK_P}.tar.gz
+"
+
+# picotool (BSD)
+# |- clipp (MIT)
+# |- pico-sdk (BSD)
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DPICO_SDK_PATH="${WORKDIR}"/${SDK_P}
+ )
+ cmake_src_configure
+}