summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-02-06 21:43:24 +0000
committerJames Le Cuirot <chewi@gentoo.org>2024-02-06 21:43:24 +0000
commit6b2df8daf9c1a7fce0471a0dd506c8468216c9b5 (patch)
tree614afe0346d5f60cef74c53ef7af64ab3054196d /dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240203.ebuild
parentdev-libs/newt: enable py3.12 (diff)
downloadgentoo-6b2df8daf9c1a7fce0471a0dd506c8468216c9b5.tar.gz
gentoo-6b2df8daf9c1a7fce0471a0dd506c8468216c9b5.tar.bz2
gentoo-6b2df8daf9c1a7fce0471a0dd506c8468216c9b5.zip
dev-embedded/raspberrypi-utils: Bump to 20240203, drop old 20240115
This fixes a current -Werror failure. I have also submitted a patch upstream to drop -Werror. Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240203.ebuild')
-rw-r--r--dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240203.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240203.ebuild b/dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240203.ebuild
new file mode 100644
index 000000000000..1c13aaaa6bdb
--- /dev/null
+++ b/dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240203.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 cmake
+
+COMMIT="1eb8c20dfa258c549139fae2b21185ac290051c5"
+
+DESCRIPTION="Raspberry Pi userspace utilities"
+HOMEPAGE="https://github.com/raspberrypi/utils"
+SRC_URI="https://github.com/raspberrypi/utils/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~arm ~arm64"
+
+DEPEND="
+ sys-apps/dtc
+"
+
+RDEPEND="
+ ${DEPEND}
+ !media-libs/raspberrypi-userland
+ !media-libs/raspberrypi-userland-bin
+"
+
+S="${WORKDIR}/utils-${COMMIT}"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ local SRC
+ rm -r "${ED}"/usr/share/bash-completion/ || die
+ for SRC in */*-completion.bash; do
+ local DEST=${SRC%-completion.bash}
+ newbashcomp "${SRC}" "${DEST##*/}"
+ done
+}