summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-12 06:06:33 +0000
committerSam James <sam@gentoo.org>2021-12-12 06:08:51 +0000
commit161feb8244249dd01360f38a98a087b8067431ce (patch)
tree6daf136cc0943fd2f1576cf9ac2f2ae26facf679 /dev-embedded
parentdev-python/ajsonrpc: initial import (diff)
downloadgentoo-161feb8244249dd01360f38a98a087b8067431ce.tar.gz
gentoo-161feb8244249dd01360f38a98a087b8067431ce.tar.bz2
gentoo-161feb8244249dd01360f38a98a087b8067431ce.zip
dev-embedded/platformio: add 5.2.3
Closes: https://bugs.gentoo.org/807748 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/platformio/Manifest1
-rw-r--r--dev-embedded/platformio/platformio-5.2.3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-embedded/platformio/Manifest b/dev-embedded/platformio/Manifest
index 86ffc433232a..ac9c341b2438 100644
--- a/dev-embedded/platformio/Manifest
+++ b/dev-embedded/platformio/Manifest
@@ -1 +1,2 @@
DIST platformio-5.1.1.tar.gz 215305 BLAKE2B a7854138dec1b5b58c4f715dde98a273ed08c0da7fb305f89490944c210737c7c500731b21a5a9cb2bf3be3925f1666ef1084992b99df46d3ee83b449baaaa35 SHA512 f74ae3cb46065379b90c7ec3574d6ff0076085cd891bf41be2f38b6c6b59f87f4d013c1da6e4825f7d831ed17136e433385ab07c3f16b31342d5415192f87eff
+DIST platformio-5.2.3.tar.gz 252483 BLAKE2B f60b83f6647333d42b5d864ea468c8104dcd5a83085a6d52f456a21792d9c94641a60f698c2a606ddd7d7b3a588723831f35ac0d3027cb0ff8b8226dabe3b62c SHA512 c11f58a984b15a3363cd29bf9a0234c1ffc772cc153310d420037416bb8834cb2b74899ccb465d69db862cc088cfcb17dcbc7d919f690b6e836dec982d5b136b
diff --git a/dev-embedded/platformio/platformio-5.2.3.ebuild b/dev-embedded/platformio/platformio-5.2.3.ebuild
new file mode 100644
index 000000000000..4e9d42889936
--- /dev/null
+++ b/dev-embedded/platformio/platformio-5.2.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="An open source ecosystem for IoT development"
+HOMEPAGE="https://platformio.org/"
+SRC_URI="https://github.com/platformio/platformio-core/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-core-${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Needs some more work to get running
+RESTRICT="test"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ =dev-python/aiofiles-0.7.0*[${PYTHON_USEDEP}]
+ <dev-python/bottle-0.13[${PYTHON_USEDEP}]
+ >=dev-python/click-7.1.2[${PYTHON_USEDEP}]
+ <dev-python/click-9[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/pyserial-3[${PYTHON_USEDEP}]
+ <dev-python/pyserial-4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ >=dev-python/semantic_version-2.8.1[${PYTHON_USEDEP}]
+ <dev-python/semantic_version-3[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.3[${PYTHON_USEDEP}]
+ <dev-python/tabulate-1[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ >=dev-python/pyelftools-0.25[${PYTHON_USEDEP}]
+ <dev-python/pyelftools-1[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-2.20.5[${PYTHON_USEDEP}]
+ =dev-python/uvicorn-0.15*[${PYTHON_USEDEP}]
+ dev-python/wsproto[${PYTHON_USEDEP}]
+ dev-python/zeroconf[${PYTHON_USEDEP}]
+ ')"
+BDEPEND="test? ( $(python_gen_cond_dep 'dev-python/jsondiff[${PYTHON_USEDEP}]') )"
+
+distutils_enable_tests pytest