summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-01-29 15:05:21 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2016-01-29 15:05:42 -0500
commit26709eaa681749df1a390b233e8e719bc6373e47 (patch)
treef6c7041b22a21ad559863fd1b31cec6a711cda3b /dev-games/wfmath/wfmath-1.0.2.ebuild
parentx11-misc/lineakd: direct users to the correct package for evtest (bug #484008) (diff)
downloadgentoo-26709eaa681749df1a390b233e8e719bc6373e47.tar.gz
gentoo-26709eaa681749df1a390b233e8e719bc6373e47.tar.bz2
gentoo-26709eaa681749df1a390b233e8e719bc6373e47.zip
dev-games/wfmath: version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-games/wfmath/wfmath-1.0.2.ebuild')
-rw-r--r--dev-games/wfmath/wfmath-1.0.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-games/wfmath/wfmath-1.0.2.ebuild b/dev-games/wfmath/wfmath-1.0.2.ebuild
new file mode 100644
index 000000000000..53fe04e1472e
--- /dev/null
+++ b/dev-games/wfmath/wfmath-1.0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Worldforge math library"
+HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/wfmath"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+ use doc && emake -C doc docs
+}
+
+src_install() {
+ default
+ use doc && dohtml doc/html/*
+ prune_libtool_files
+}