summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-04 08:46:19 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-04 08:46:37 +0100
commit530052c1e9a480e6a9e1a645aaaa4fe810714488 (patch)
tree4f53ba37416c5872cd54999839531988d91134df /dev-haskell/cassava/cassava-0.5.2.0.ebuild
parentdev-haskell/text-short: new package, a depend of cassava-0.5 (diff)
downloadgentoo-530052c1e9a480e6a9e1a645aaaa4fe810714488.tar.gz
gentoo-530052c1e9a480e6a9e1a645aaaa4fe810714488.tar.bz2
gentoo-530052c1e9a480e6a9e1a645aaaa4fe810714488.zip
dev-haskell/cassava: bump up to 0.5.2.0
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/cassava/cassava-0.5.2.0.ebuild')
-rw-r--r--dev-haskell/cassava/cassava-0.5.2.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/cassava/cassava-0.5.2.0.ebuild b/dev-haskell/cassava/cassava-0.5.2.0.ebuild
new file mode 100644
index 000000000000..73aa92acc462
--- /dev/null
+++ b/dev-haskell/cassava/cassava-0.5.2.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A CSV parsing and encoding library"
+HOMEPAGE="https://github.com/hvr/cassava"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.11.3.0:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
+ >=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
+ <dev-haskell/hashable-1.4:=[profile?]
+ >=dev-haskell/nats-1:=[profile?] <dev-haskell/nats-1.2:=[profile?]
+ >=dev-haskell/only-0.1:=[profile?] <dev-haskell/only-0.1.1:=[profile?]
+ >=dev-haskell/scientific-0.3.4.7:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/semigroups-0.18.2:=[profile?] <dev-haskell/semigroups-0.20:=[profile?]
+ <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/text-short-0.1:=[profile?] <dev-haskell/text-short-0.2:=[profile?]
+ <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.8:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( <dev-haskell/hunit-1.7
+ >=dev-haskell/quickcheck-2.13 <dev-haskell/quickcheck-2.14
+ >=dev-haskell/quickcheck-instances-0.3.12 <dev-haskell/quickcheck-instances-0.4
+ >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.3 <dev-haskell/test-framework-hunit-0.4
+ >=dev-haskell/test-framework-quickcheck2-0.3 <dev-haskell/test-framework-quickcheck2-0.4 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >= 4.5 && < 4.14' 'base >= 4.5'
+}