summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-11 19:21:40 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:02 +0000
commit24f37ebd6fb0bfd5c338cab255834265262e1e26 (patch)
treebf7a59fa0a6ed4fe0e0fbdaf58ee970b3a2531fd /dev-haskell/data-fix/data-fix-0.3.2.ebuild
parentdev-haskell/data-default: keyword 0.7.1.1 for ~ppc64 (diff)
downloadgentoo-24f37ebd6fb0bfd5c338cab255834265262e1e26.tar.gz
gentoo-24f37ebd6fb0bfd5c338cab255834265262e1e26.tar.bz2
gentoo-24f37ebd6fb0bfd5c338cab255834265262e1e26.zip
dev-haskell/data-fix: new package, add 0.3.2
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/data-fix/data-fix-0.3.2.ebuild')
-rw-r--r--dev-haskell/data-fix/data-fix-0.3.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/data-fix/data-fix-0.3.2.ebuild b/dev-haskell/data-fix/data-fix-0.3.2.ebuild
new file mode 100644
index 000000000000..e16fda4a7352
--- /dev/null
+++ b/dev-haskell/data-fix/data-fix-0.3.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+CABAL_HACKAGE_REVISION="2"
+inherit haskell-cabal
+
+DESCRIPTION="Fixpoint data types"
+HOMEPAGE="https://github.com/spell-music/data-fix"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal -> ${PF}.cabal"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/hashable-1.2.7.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+BDEPEND="app-text/dos2unix"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
+
+ # Convert to unix line endings
+ dos2unix "${S}/${PN}.cabal" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}