summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:07:42 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:38 +0100
commit2bc59b4f99c7bc1a38af1f8505c27ca757c59194 (patch)
treef066b3fc8b170df72cd7692f5aaaa537f701ae4a /dev-haskell/hdbc-postgresql
parentdev-haskell/haskeline: Hackage revision bump (diff)
downloadgentoo-2bc59b4f99c7bc1a38af1f8505c27ca757c59194.tar.gz
gentoo-2bc59b4f99c7bc1a38af1f8505c27ca757c59194.tar.bz2
gentoo-2bc59b4f99c7bc1a38af1f8505c27ca757c59194.zip
dev-haskell/hdbc-postgresql: add 2.5.0.1
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/hdbc-postgresql')
-rw-r--r--dev-haskell/hdbc-postgresql/Manifest1
-rw-r--r--dev-haskell/hdbc-postgresql/hdbc-postgresql-2.5.0.1.ebuild47
-rw-r--r--dev-haskell/hdbc-postgresql/metadata.xml14
3 files changed, 56 insertions, 6 deletions
diff --git a/dev-haskell/hdbc-postgresql/Manifest b/dev-haskell/hdbc-postgresql/Manifest
index 94d3c2bb0ab1..45507d0c9efd 100644
--- a/dev-haskell/hdbc-postgresql/Manifest
+++ b/dev-haskell/hdbc-postgresql/Manifest
@@ -1 +1,2 @@
DIST HDBC-postgresql-2.5.0.0.tar.gz 24404 BLAKE2B 8fc7ca3b2fa6d379af4f9dd4b801921274a6c352b05e95b836f0208304e2e2a6cc18df765b432767cb6ef9fa3f99ee0488e095b82091c12838f6b3220f114453 SHA512 3a81708b119e156e08265b02f3b27ac764a854b8d79f7ed1bd1c191b897ead10d231854f0edaf1f27d76af18e4330c67b7ced0328830e013bab88ec47f668a4d
+DIST hdbc-postgresql-2.5.0.1.tar.gz 24975 BLAKE2B 2d71b0624bbd5a0ca18bda5060a0fb2aed5528120109631660832ecea11101af2e3a9f545d86659ca67bda44e9eb86f5662158668bb72ddc068770416146ca67 SHA512 0f693fc7bf4f78805f097523203024801b445348441b9cbb5f22a6e55fc0e3409fc4f1c08c7a20299bb96f407286d994c890f8d05a52cb883755be5246bcd4c0
diff --git a/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.5.0.1.ebuild b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.5.0.1.ebuild
new file mode 100644
index 000000000000..b90c4758ef83
--- /dev/null
+++ b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.5.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+#hackport: flags: -buildtests,+mintime15,+splitbase
+
+CABAL_PN="HDBC-postgresql"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+# error: Connection.hsc:34:10: fatal error: pg_config.h: No such file or directory
+RESTRICT="test" # Missing files
+
+DESCRIPTION="PostgreSQL driver for HDBC"
+HOMEPAGE="https://github.com/hdbc/hdbc-postgresql"
+
+LICENSE="BSD"
+
+# For some reason, the slot was previously set to 2. Changing this could cause
+# problems as haskell-updater tries to reinstall a version of the same slot.
+# This should be changed at some point, but currently the version in ::gentoo
+# is also set to 2.
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-db/postgresql-7:*
+ dev-haskell/convertible:=[profile?]
+ >=dev-haskell/hdbc-2.2.0:2=[profile?]
+ dev-haskell/old-time:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-buildtests \
+ --flag=mintime15 \
+ --flag=splitbase
+}
diff --git a/dev-haskell/hdbc-postgresql/metadata.xml b/dev-haskell/hdbc-postgresql/metadata.xml
index 86e6ee48b925..c5d81d92f84e 100644
--- a/dev-haskell/hdbc-postgresql/metadata.xml
+++ b/dev-haskell/hdbc-postgresql/metadata.xml
@@ -1,10 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- </maintainer>
- <upstream>
- <remote-id type="github">hdbc/hdbc-postgresql</remote-id>
- </upstream>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="hackage">HDBC-postgresql</remote-id>
+ <remote-id type="github">hdbc/hdbc-postgresql</remote-id>
+ </upstream>
</pkgmetadata>