summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-19 21:57:36 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-19 22:29:01 +0000
commita9d6b220f2f79ba6ccee13aee24715cea39d926e (patch)
treee4fbb25749fec681d956db5815c9bf42b52a3830 /dev-haskell/http2/http2-1.3.1.ebuild
parentdev-haskell/psqueues: new package, a depend of dev-haskell/http2 (diff)
downloadgentoo-a9d6b220f2f79ba6ccee13aee24715cea39d926e.tar.gz
gentoo-a9d6b220f2f79ba6ccee13aee24715cea39d926e.tar.bz2
gentoo-a9d6b220f2f79ba6ccee13aee24715cea39d926e.zip
dev-haskell/http2: nw package, a depend of dev-haskell/warp
HTTP/2.0 library including frames and HPACK. Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-haskell/http2/http2-1.3.1.ebuild')
-rw-r--r--dev-haskell/http2/http2-1.3.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-haskell/http2/http2-1.3.1.ebuild b/dev-haskell/http2/http2-1.3.1.ebuild
new file mode 100644
index 000000000000..49e26aa43186
--- /dev/null
+++ b/dev-haskell/http2/http2-1.3.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+#hackport: flags: -devel
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="HTTP/2.0 library including frames and HPACK"
+HOMEPAGE="http://hackage.haskell.org/package/http2"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # missing files
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/aeson-pretty:=[profile?]
+ dev-haskell/bytestring-builder:=[profile?]
+ dev-haskell/hex:=[profile?]
+ dev-haskell/psqueues:=[profile?]
+ dev-haskell/stm:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ dev-haskell/word8:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/doctest-0.9.3
+ dev-haskell/glob
+ >=dev-haskell/hspec-1.3
+ dev-haskell/mwc-random )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-devel
+}