summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-11 20:06:14 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:32 +0000
commit258d0cfc06c949fb69f372db4e046a659ae322e8 (patch)
tree312ec8951e512c11ea5138a9ad2d2ee3f7a815c2 /dev-haskell/parsec
parentdev-haskell/parallel: keyword 3.2.2.0 for ~ppc64 (diff)
downloadgentoo-258d0cfc06c949fb69f372db4e046a659ae322e8.tar.gz
gentoo-258d0cfc06c949fb69f372db4e046a659ae322e8.tar.bz2
gentoo-258d0cfc06c949fb69f372db4e046a659ae322e8.zip
dev-haskell/parsec: revbump 3.1.14.0-r1
https://github.com/gentoo-haskell/gentoo-haskell/commit/0ecde68c329e2cd6b1448551cda3079b68c45906 Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/parsec')
-rw-r--r--dev-haskell/parsec/parsec-3.1.14.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-haskell/parsec/parsec-3.1.14.0-r1.ebuild b/dev-haskell/parsec/parsec-3.1.14.0-r1.ebuild
new file mode 100644
index 000000000000..aefa3f757c26
--- /dev/null
+++ b/dev-haskell/parsec/parsec-3.1.14.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # Circular depens: test-suite"
+# break circular dependencies:
+# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
+CABAL_FEATURES+=" nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Monadic parser combinators"
+HOMEPAGE="https://github.com/haskell/parsec"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+# keep in sync with ghc-8.8
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RESTRICT=test # circular dependencies: dev-haskell/base-orphans->cabal->parsec[test]->test-framework-hunit->test-framework->base-orphans
+
+RDEPEND=">=dev-haskell/mtl-1.1.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ >=dev-haskell/text-0.11.3.1:=[profile?] <dev-haskell/text-1.3:=[profile?]
+"
+DEPEND="${RDEPEND}"
+
+CABAL_CORE_LIB_GHC_PV="PM:8.8.4-r1 PM:8.10.5-r1 PM:8.10.6 PM:8.10.7 PM:9.0.1-r1 PM:9.0.2 PM:9999"