summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuan Liao <liaoyuan@gmail.com>2022-01-28 09:25:35 -0800
committerMiroslav Šulc <fordfrog@gentoo.org>2022-02-04 09:17:41 +0100
commita71ad958f9aa2ccbaff300ef57680afe3cb240ae (patch)
tree90069af6ee0cdbf299ccfd5567d99bfa594ce988 /dev-java/antlr-runtime/antlr-runtime-4.9.3.ebuild
parentdev-java/jakarta-json-api: Initial import (diff)
downloadgentoo-a71ad958f9aa2ccbaff300ef57680afe3cb240ae.tar.gz
gentoo-a71ad958f9aa2ccbaff300ef57680afe3cb240ae.tar.bz2
gentoo-a71ad958f9aa2ccbaff300ef57680afe3cb240ae.zip
dev-java/antlr-runtime: Add 4.9.3
Signed-off-by: Yuan Liao <liaoyuan@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24006/commits/d10efff65c11fc4b7e401bd765721978510bb7ef Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/antlr-runtime/antlr-runtime-4.9.3.ebuild')
-rw-r--r--dev-java/antlr-runtime/antlr-runtime-4.9.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-java/antlr-runtime/antlr-runtime-4.9.3.ebuild b/dev-java/antlr-runtime/antlr-runtime-4.9.3.ebuild
new file mode 100644
index 000000000000..e97dfbd712e3
--- /dev/null
+++ b/dev-java/antlr-runtime/antlr-runtime-4.9.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Without annotation processing using runtime-testsuite/processors,
+# the tests are bound to fail. However, the annotation processor
+# has been dropped from the 'master' branch as of January 2022, so
+# when updating this package to a new upstream version, please
+# check if it is possible to enable the tests and pass them.
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="org.antlr:antlr4-runtime:4.9.3"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="${PN%-runtime}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="ANTLR 4 Runtime"
+HOMEPAGE="https://www.antlr.org/"
+SRC_URI="https://github.com/antlr/antlr4/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+
+S="${WORKDIR}/${MY_PN}4-${PV}"
+
+JAVA_SRC_DIR="runtime/Java/src"