summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-07-21 19:10:46 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-07-28 20:29:22 +0200
commit18b6ffd44d141a080e4d036f914d590e1fb495f4 (patch)
tree7f835d46f34ca394ce612496a0c66fb13d2daaf2 /dev-java/hawtjni-runtime/hawtjni-runtime-1.18.ebuild
parentdev-java/plexus-classworlds: add 2.6.0 (diff)
downloadgentoo-18b6ffd44d141a080e4d036f914d590e1fb495f4.tar.gz
gentoo-18b6ffd44d141a080e4d036f914d590e1fb495f4.tar.bz2
gentoo-18b6ffd44d141a080e4d036f914d590e1fb495f4.zip
dev-java/hawtjni-runtime: add 1.18
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/26510 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java/hawtjni-runtime/hawtjni-runtime-1.18.ebuild')
-rw-r--r--dev-java/hawtjni-runtime/hawtjni-runtime-1.18.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-java/hawtjni-runtime/hawtjni-runtime-1.18.ebuild b/dev-java/hawtjni-runtime/hawtjni-runtime-1.18.ebuild
new file mode 100644
index 000000000000..13748884cb64
--- /dev/null
+++ b/dev-java/hawtjni-runtime/hawtjni-runtime-1.18.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID=""
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A JNI code generator based on the generator used by the Eclipse SWT project"
+HOMEPAGE="https://github.com/fusesource/hawtjni"
+SRC_URI="https://github.com/fusesource/hawtjni/archive/hawtjni-project-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=( {changelog,notice,readme}.md )
+
+S="${WORKDIR}/hawtjni-hawtjni-project-${PV}"
+
+JAVA_AUTOMATIC_MODULE_NAME="org.fusesource.hawtjni.runtime"
+JAVA_SRC_DIR="${PN}/src/main/java"