summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/httpcomponents-core/httpcomponents-core-4.4.1-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/httpcomponents-core/httpcomponents-core-4.4.1-r1.ebuild')
-rw-r--r--dev-java/httpcomponents-core/httpcomponents-core-4.4.1-r1.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/dev-java/httpcomponents-core/httpcomponents-core-4.4.1-r1.ebuild b/dev-java/httpcomponents-core/httpcomponents-core-4.4.1-r1.ebuild
new file mode 100644
index 000000000000..7cb42e64fea6
--- /dev/null
+++ b/dev-java/httpcomponents-core/httpcomponents-core-4.4.1-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source examples test"
+
+# "components"
+CMPT=${PN%%-*}
+
+# "core"
+CORE=${PN##*-}
+
+# "httpcore"
+HTTPCORE="http${CORE}"
+
+# "httpcore-nio"
+HTTPNIO="${HTTPCORE}-nio"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A low level toolset of Java components focused on HTTP and associated protocols"
+HOMEPAGE="http://hc.apache.org/index.html"
+SRC_URI="mirror://apache/httpcomponents/${HTTPCORE}/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="4.4"
+KEYWORDS="amd64 x86"
+
+DEPEND=">=virtual/jdk-1.6
+ test? (
+ dev-java/commons-logging:0
+ dev-java/ant-junit:0
+ dev-java/mockito:0
+ )"
+RDEPEND=">=virtual/jre-1.6"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_BUILD_TARGET="package"
+EANT_GENTOO_CLASSPATH_EXTRA="${S}/${HTTPCORE}/target/${HTTPCORE}-${PV}.jar"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-${HTTPCORE}-build.xml ${HTTPCORE}/build.xml
+ cp "${FILESDIR}"/${P}-${HTTPNIO}-build.xml ${HTTPNIO}/build.xml
+
+ # Why have these classes been deprecated although other libraries are built
+ # on them (i.e. httpcomponents-client) is mindboggling. See bug 553234.
+ cp -r "${S}"/httpcore/src/main/java-deprecated/* \
+ "${S}"/httpcore/src/main/java/* || die
+ cp -r "${S}"/httpcore-nio/src/main/java-deprecated/* \
+ "${S}"/httpcore-nio/src/main/java/* || die
+}
+
+src_compile() {
+ # first, compile httpcore module
+ EANT_BUILD_XML="${HTTPCORE}/build.xml" java-pkg-2_src_compile
+
+ # then, httpnio module
+ EANT_BUILD_XML="${HTTPNIO}/build.xml" java-pkg-2_src_compile
+}
+
+EANT_TEST_GENTOO_CLASSPATH="
+ commons-logging
+ mockito
+"
+
+src_test() {
+ # run junit tests for httpcore module
+ EANT_BUILD_XML="${HTTPCORE}/build.xml" java-pkg-2_src_test
+
+ # run junit tests for httpcore-nio module
+ EANT_BUILD_XML="${HTTPNIO}/build.xml" java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar ${HTTPCORE}/target/${HTTPCORE}-${PV}.jar ${HTTPCORE}.jar
+ java-pkg_newjar ${HTTPNIO}/target/${HTTPNIO}-${PV}.jar ${HTTPNIO}.jar
+
+ use source && java-pkg_dosrc httpcore{,-nio}/src/main/java
+ use examples && java-pkg_doexamples httpcore{,-nio}/src/examples
+
+ dodoc {README,RELEASE_NOTES,NOTICE}.txt
+}