summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErvin Peters <coder@ervnet.de>2019-10-25 09:39:37 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2019-10-25 09:50:57 +0200
commitd78c25129743e2b00e34c6f42f6e0c72b9ad4dbc (patch)
tree5a37af8dfe8373097197ecf39b43a9d76802221a /dev-java/java-sdk-docs/java-sdk-docs-11.0.5.ebuild
parentdev-java/java-sdk-docs: version bump to 11.0.4 (diff)
downloadgentoo-d78c25129743e2b00e34c6f42f6e0c72b9ad4dbc.tar.gz
gentoo-d78c25129743e2b00e34c6f42f6e0c72b9ad4dbc.tar.bz2
gentoo-d78c25129743e2b00e34c6f42f6e0c72b9ad4dbc.zip
dev-java/java-sdk-docs: Bump zo 11.0.5
older Versions of 11 not available anyore Signed-off-by: Ervin Peters <ervin.peters@ervnet.de> Package-Manager: Portage-2.3.76, Repoman-2.3.16 Closes: https://github.com/gentoo/gentoo/pull/13260 Closes: https://bugs.gentoo.org/698078 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/java-sdk-docs/java-sdk-docs-11.0.5.ebuild')
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-11.0.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-11.0.5.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-11.0.5.ebuild
new file mode 100644
index 000000000000..7dfaec9ffefc
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-11.0.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DOWNLOAD_URL="https://www.oracle.com/technetwork/java/javase/documentation/jdk11-doc-downloads-5097203.html"
+
+SLOT="${PV%%.*}"
+DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
+HOMEPAGE="https://docs.oracle.com/javase/${SLOT}"
+SRC_URI="jdk-${PV}_doc-all.zip"
+LICENSE="oracle-java-documentation-${SLOT}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+RESTRICT="fetch"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${SRC_URI} from"
+ einfo "${DOWNLOAD_URL}"
+ einfo "by agreeing to the license and place it in your distfiles directory."
+ einfo ""
+ einfo "If you find the file on the download page replaced with a higher"
+ einfo "version, please report it in bug #67266 (link below)."
+ einfo ""
+ einfo "If emerge fails because of a checksum error, it is possible that"
+ einfo "the upstream release changed without renaming. Try downloading the file"
+ einfo "again (or a newer revision if available). Otherwise report this to"
+ einfo "https://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install() {
+ insinto /usr/share/doc/${PN}-${SLOT}/html
+ doins -r index.html */
+}