summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValérian Rousset <tharvik@users.noreply.github.com>2023-04-14 20:47:15 +0200
committerSam James <sam@gentoo.org>2023-05-20 10:21:45 +0100
commite67a6427adf6158223630c63aae98e0bbce33edd (patch)
tree6b30024008dc7ed9f4c57f2a502290dbd7430809 /dev-java/jbcrypt/jbcrypt-0.4.ebuild
parentdev-java/hashcash: new package, add 1.1 (diff)
downloadgentoo-e67a6427adf6158223630c63aae98e0bbce33edd.tar.gz
gentoo-e67a6427adf6158223630c63aae98e0bbce33edd.tar.bz2
gentoo-e67a6427adf6158223630c63aae98e0bbce33edd.zip
dev-java/jbcrypt: new package, add 0.4
Signed-off-by: Valérian Rousset <tharvik@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-java/jbcrypt/jbcrypt-0.4.ebuild')
-rw-r--r--dev-java/jbcrypt/jbcrypt-0.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-java/jbcrypt/jbcrypt-0.4.ebuild b/dev-java/jbcrypt/jbcrypt-0.4.ebuild
new file mode 100644
index 000000000000..49671984ecdb
--- /dev/null
+++ b/dev-java/jbcrypt/jbcrypt-0.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="org.mindrot:jbcrypt:0.4"
+JAVA_TESTING_FRAMEWORKS="junit"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java implementation of OpenBSD's Blowfish password hashing code"
+HOMEPAGE="https://www.mindrot.org/projects/jBCrypt"
+SRC_URI="https://www.mindrot.org/files/jBCrypt/jBCrypt-${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+S="${WORKDIR}/jBCrypt-${PV}"
+
+JAVA_SRC_DIR="src"
+JAVA_TEST_SRC_DIR="test"
+JAVA_TEST_GENTOO_CLASSPATH="junit"