summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jvmstat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jvmstat')
-rw-r--r--dev-java/jvmstat/Manifest1
-rw-r--r--dev-java/jvmstat/jvmstat-3.0.ebuild53
-rw-r--r--dev-java/jvmstat/metadata.xml5
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-java/jvmstat/Manifest b/dev-java/jvmstat/Manifest
new file mode 100644
index 000000000000..3833ec68f358
--- /dev/null
+++ b/dev-java/jvmstat/Manifest
@@ -0,0 +1 @@
+DIST jvmstat-3_0.zip 153629 SHA256 3d3fad22aa65f356f6ecca050216f814fcdf20c0611a1f689969991d7a1ccb79
diff --git a/dev-java/jvmstat/jvmstat-3.0.ebuild b/dev-java/jvmstat/jvmstat-3.0.ebuild
new file mode 100644
index 000000000000..15b16dc670d6
--- /dev/null
+++ b/dev-java/jvmstat/jvmstat-3.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2 versionator
+
+MY_PV=$(replace_version_separator 1 '_')
+DESCRIPTION="Monitoring APIs and tools for monitoring the performance of the JVM in production environments"
+HOMEPAGE="http://java.sun.com/performance/jvmstat/"
+SRC_URI="jvmstat-${MY_PV}.zip"
+
+LICENSE="sun-bcla-jvmstat"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RESTRICT="fetch strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/jvmstat/"
+
+INSTTO="/opt/${PN}"
+
+pkg_nofetch() {
+
+ einfo "Please go to following URL:"
+ einfo " ${HOMEPAGE}"
+ einfo "download file named ${SRC_URI} and place it in:"
+ einfo " ${DISTDIR}"
+
+}
+
+src_install() {
+
+ dodir "${INSTTO}"
+ cd "${S}"
+ cp -r jars bin "${D}/${INSTTO}"
+
+ dodoc README
+ use doc && dodoc -r docs
+
+ dodir /opt/bin
+ cat > "${D}/opt/bin/visualgc" <<-EOF
+ #!/bin/bash
+ export JVMSTAT_JAVA_HOME=$(java-config -O)
+ cd /opt/jvmstat/bin/
+ ./visualgc \${@}
+ EOF
+ fperms 755 /opt/bin/visualgc
+
+}
diff --git a/dev-java/jvmstat/metadata.xml b/dev-java/jvmstat/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/dev-java/jvmstat/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>