summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2021-06-08 19:05:44 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-07-10 12:51:23 +0200
commit89408c7a7b45871647b51ada641abebab16ac90f (patch)
tree95e969bdff1f7b67efda64e19e5dbf51230d8e2b /dev-java
parentx11-misc/synergy: amd64 stable wrt bug #799941 (diff)
downloadgentoo-89408c7a7b45871647b51ada641abebab16ac90f.tar.gz
gentoo-89408c7a7b45871647b51ada641abebab16ac90f.tar.bz2
gentoo-89408c7a7b45871647b51ada641abebab16ac90f.zip
dev-java/httpcore: new package
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/21197/commits/2f0a4734dea3c720e590df20203a8f13cc578faf Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/httpcore/Manifest1
-rw-r--r--dev-java/httpcore/httpcore-4.4.14.ebuild54
-rw-r--r--dev-java/httpcore/metadata.xml7
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-java/httpcore/Manifest b/dev-java/httpcore/Manifest
new file mode 100644
index 000000000000..58259b00cd12
--- /dev/null
+++ b/dev-java/httpcore/Manifest
@@ -0,0 +1 @@
+DIST httpcomponents-core-4.4.14-src.tar.gz 591869 BLAKE2B d6f4900d8781cf7189edb2dfa9c1157b02584e8c66cde02dc261b0e29cdfb971e0323ce4478966b8e125df475ab1014fbee5b4bdf411eb118647f47f95c8f1a7 SHA512 9c713c7ea4e966a35ed391bc2a3aa10a0963cd21978c028dbd0790c9c2a6592385c7b2f135ea2836e6c495d9faea1bdcc65aa994bd5548bc2d84db38d5dbb713
diff --git a/dev-java/httpcore/httpcore-4.4.14.ebuild b/dev-java/httpcore/httpcore-4.4.14.ebuild
new file mode 100644
index 000000000000..5584b7dab67a
--- /dev/null
+++ b/dev-java/httpcore/httpcore-4.4.14.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom httpcore/pom.xml --download-uri https://mirror.netcologne.de/apache.org//httpcomponents/httpcore/source/httpcomponents-core-4.4.14-src.tar.gz --slot 0 --keywords "~amd64 ~ppc64 ~x86" --ebuild httpcomponents-core-4.4.14.ebuild
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="org.apache.httpcomponents:httpcore:4.4.14"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Apache HttpComponents Core (blocking I/O)"
+HOMEPAGE="https://hc.apache.org/httpcomponents-core-ga"
+SRC_URI="mirror://apache/httpcomponents/httpcore/source/httpcomponents-core-${PV}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+# Compile dependencies
+# POM: httpcore/pom.xml
+# test? commons-logging:commons-logging:1.2 -> >=dev-java/commons-logging-1.2:0
+# test? junit:junit:4.12 -> >=dev-java/junit-4.13.2:4
+# test? org.mockito:mockito-core:1.10.19 -> >=dev-java/mockito-1.9.5:0
+
+DEPEND=">=virtual/jdk-1.8:*
+ test? (
+ dev-java/commons-logging:0
+ dev-java/mockito:0
+ )"
+
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=( ../{LICENSE,NOTICE,README,RELEASE_NOTES}.txt )
+
+S="${WORKDIR}/httpcore"
+
+JAVA_SRC_DIR=(
+ "src/main/java"
+ "src/main/java-deprecated"
+)
+JAVA_RESOURCE_DIRS="src/main/resources"
+
+JAVA_TEST_GENTOO_CLASSPATH="commons-logging,junit-4,mockito"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_RESOURCE_DIRS="src/test/resources"
+
+src_install() {
+ default
+ java-pkg-simple_src_install
+}
diff --git a/dev-java/httpcore/metadata.xml b/dev-java/httpcore/metadata.xml
new file mode 100644
index 000000000000..0d49beafc75d
--- /dev/null
+++ b/dev-java/httpcore/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>