summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-04-06 13:34:45 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-04-27 10:57:14 +0200
commitd03832c00aee6e88e047b884c3749e2385b650f6 (patch)
tree4a56a134d9563a989d5c7b18a61825c196098af2 /dev-java
parentdev-ml/textutils_kernel: add to tree (diff)
downloadgentoo-d03832c00aee6e88e047b884c3749e2385b650f6.tar.gz
gentoo-d03832c00aee6e88e047b884c3749e2385b650f6.tar.bz2
gentoo-d03832c00aee6e88e047b884c3749e2385b650f6.zip
dev-java/xmlgraphics-commons: enable tests
Bug: https://bugs.gentoo.org/832058 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/24989 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/xmlgraphics-commons/metadata.xml11
-rw-r--r--dev-java/xmlgraphics-commons/xmlgraphics-commons-2.7-r1.ebuild70
2 files changed, 77 insertions, 4 deletions
diff --git a/dev-java/xmlgraphics-commons/metadata.xml b/dev-java/xmlgraphics-commons/metadata.xml
index 6021501589e0..4dcc12913cbb 100644
--- a/dev-java/xmlgraphics-commons/metadata.xml
+++ b/dev-java/xmlgraphics-commons/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
-</maintainer>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">apache/xmlgraphics-commons</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-java/xmlgraphics-commons/xmlgraphics-commons-2.7-r1.ebuild b/dev-java/xmlgraphics-commons/xmlgraphics-commons-2.7-r1.ebuild
new file mode 100644
index 000000000000..ad42da6ed305
--- /dev/null
+++ b/dev-java/xmlgraphics-commons/xmlgraphics-commons-2.7-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri mirror://apache/xmlgraphics/commons/source/2.7-src.tar.gz --slot 2 --keywords "~amd64 ~arm64 ~ppc64 ~x86" --ebuild xmlgraphics-commons-2.7.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="org.apache.xmlgraphics:xmlgraphics-commons:2.7"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="XML Graphics Commons"
+HOMEPAGE="https://xmlgraphics.apache.org/commons/"
+SRC_URI="mirror://apache/xmlgraphics/commons/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+# Common dependencies
+# POM: pom.xml
+# commons-io:commons-io:1.3.2 -> >=dev-java/commons-io-2.11.0:1
+# commons-logging:commons-logging:1.2 -> >=dev-java/commons-logging-1.2:0
+
+CP_DEPEND="
+ dev-java/commons-io:1
+ dev-java/commons-logging:0
+"
+
+# Compile dependencies
+# POM: pom.xml
+# test? junit:junit:4.11 -> >=dev-java/junit-4.13.2:4
+# test? org.mockito:mockito-core:2.28.2 -> !!!suitable-mavenVersion-not-found!!!
+# test? xml-resolver:xml-resolver:1.2 -> >=dev-java/xml-commons-resolver-1.2:0
+
+DEPEND="${CP_DEPEND}
+ >=virtual/jdk-1.8:*
+ test? (
+ dev-java/mockito:4
+ dev-java/xml-commons-resolver:0
+ )"
+
+RDEPEND="${CP_DEPEND}
+ >=virtual/jre-1.8:*"
+
+S="${WORKDIR}/${P}"
+
+JAVA_SRC_DIR="src/main/java"
+JAVA_RESOURCE_DIRS="src/main/resources"
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4,mockito-4,xml-commons-resolver"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_RESOURCE_DIRS="src/test/resources"
+
+# There are test failures, bug #832058
+JAVA_TEST_EXCLUDES=(
+ "org.apache.xmlgraphics.image.codec.tiff.TIFFImageEncoderTestCase"
+ "org.apache.xmlgraphics.image.loader.impl.ImageLoaderImageIOTestCase"
+ "org.apache.xmlgraphics.io.XmlSourceUtilTestCase"
+ "org.apache.xmlgraphics.ps.dsc.ListenerTestCase"
+ "org.apache.xmlgraphics.xmp.XMPParserTestCase"
+)
+
+src_install() {
+ java-pkg-simple_src_install
+ einstalldocs # https://bugs.gentoo.org/789582
+}