summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-09-24 09:08:03 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-09-24 09:14:14 +0200
commitf73ec67966768edf2d3245715bf9a2c96504a062 (patch)
tree9308f3208ef6cf528f8ab843e771e4e0025139b1 /dev-java
parentapp-editors/mousepad: x86 stable wrt bug #814494 (diff)
downloadgentoo-f73ec67966768edf2d3245715bf9a2c96504a062.tar.gz
gentoo-f73ec67966768edf2d3245715bf9a2c96504a062.tar.bz2
gentoo-f73ec67966768edf2d3245715bf9a2c96504a062.zip
dev-java/commons-io: bump to 2.11.0
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-io/Manifest1
-rw-r--r--dev-java/commons-io/commons-io-2.11.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-java/commons-io/Manifest b/dev-java/commons-io/Manifest
index e3fecd8f067d..5b36c1c384bb 100644
--- a/dev-java/commons-io/Manifest
+++ b/dev-java/commons-io/Manifest
@@ -1 +1,2 @@
+DIST commons-io-2.11.0-sources.tar.gz 498841 BLAKE2B e45ae4400246d7469e8628f08d2f647ea670b994360c1150fe1f414beee5177e7af7c94589a5c81ce6996f2fb755441f29080ca9b69b98cb5ae1ad897f8f00b5 SHA512 e2ab8ebc9c328093a460f8f5f96c80bb45f5073ec7aaa0beabdcdeac2e97324292eab2e2cb8b64d8e78b2c5d89048ba84e50daa0965dffcbe2fd0da7ab789ee3
DIST commons-io-2.8.0-sources.tar.gz 445833 BLAKE2B 4fc6f9b66fa88adfc110742bd3eab55cbe165552f71d665f70fd54d4b0b79c4e76b45fccdb78c6ef64e476f54efc8b51adc9b2d7e880c71dbdb6bc5883d2fe55 SHA512 6189c72eff8661bfb8cfed95dd7ee32578b24b50f6586d4628a4dbfd3618853a72eb73da311729e55742ace47b2d38d3ce130ab87b684494d8ce33d1ccf14a2d
diff --git a/dev-java/commons-io/commons-io-2.11.0.ebuild b/dev-java/commons-io/commons-io-2.11.0.ebuild
new file mode 100644
index 000000000000..ef103119de08
--- /dev/null
+++ b/dev-java/commons-io/commons-io-2.11.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://mirror.dkm.cz/apache//commons/io/source/commons-io-2.11.0-src.tar.gz --slot 0 --keywords "~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris" --ebuild commons-io-2.11.0.ebuild
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="commons-io:commons-io:2.11.0"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Utility classes, stream implementations, file filters, and much more."
+HOMEPAGE="https://commons.apache.org/proper/commons-io/"
+SRC_URI="mirror://apache/commons/io/source/${P}-src.tar.gz -> ${P}-sources.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+# Compile dependencies
+# POM: pom.xml
+# test? com.google.jimfs:jimfs:1.2 -> !!!groupId-not-found!!!
+# test? org.apache.commons:commons-lang3:3.12.0 -> >=dev-java/commons-lang-3.12.0:3.6
+# test? org.junit-pioneer:junit-pioneer:1.4.2 -> !!!groupId-not-found!!!
+# test? org.junit.jupiter:junit-jupiter:5.7.2 -> !!!groupId-not-found!!!
+# test? org.mockito:mockito-inline:3.11.2 -> !!!artifactId-not-found!!!
+# test? org.openjdk.jmh:jmh-core:1.32 -> !!!groupId-not-found!!!
+# test? org.openjdk.jmh:jmh-generator-annprocess:1.32 -> !!!groupId-not-found!!!
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+ test? (
+ >=dev-java/commons-lang-3.12.0:3.6
+ )
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+
+# some test dependencies are missing
+RESTRICT="test"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ENCODING="iso-8859-1"
+
+JAVA_SRC_DIR="src/main/java"
+
+JAVA_TEST_GENTOO_CLASSPATH="commons-lang-3.6"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_RESOURCE_DIRS=(
+ "src/test/resources"
+)