summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-08-27 03:16:43 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-08-27 03:27:02 +0200
commit3f50d6f5c1b74194e7a32bbe2ab741f9d540ce45 (patch)
tree83e5679bf64fd066aedeb7b41dc28f47a082398f /dev-lang/dafny-bin
parentapp-emacs/compat: bump to 28.1.2.2 (diff)
downloadgentoo-3f50d6f5c1b74194e7a32bbe2ab741f9d540ce45.tar.gz
gentoo-3f50d6f5c1b74194e7a32bbe2ab741f9d540ce45.tar.bz2
gentoo-3f50d6f5c1b74194e7a32bbe2ab741f9d540ce45.zip
dev-lang/dafny-bin: bump to 3.8.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang/dafny-bin')
-rw-r--r--dev-lang/dafny-bin/Manifest1
-rw-r--r--dev-lang/dafny-bin/dafny-bin-3.8.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-lang/dafny-bin/Manifest b/dev-lang/dafny-bin/Manifest
index 061ade61d849..fb17c2418c44 100644
--- a/dev-lang/dafny-bin/Manifest
+++ b/dev-lang/dafny-bin/Manifest
@@ -1,3 +1,4 @@
DIST dafny-3.7.1-x64-ubuntu-16.04.zip 76008449 BLAKE2B 5685dcc04e750960fa9bed536d6fae8f70979be899349eaab54bb7045a6e6a9849988be10db3ad33c9096a8d91d17f7b055e50507f736a169aa4fdcb6654b8f6 SHA512 689f3a125e336806c7fe15a8e0cc95e3242f99b719bfae57715313699880c21b13cf2eddfe4163e40da8de20f81c7148dce132dbc511b7a5c2320c1e96d2040a
DIST dafny-3.7.2-x64-ubuntu-16.04.zip 76166815 BLAKE2B a0b2531dedbe413298b6d92a65c854d70785d8732688d1e3556a5e5dc8c268b36dbb994e35960f2a18ecf40e64a6ff0912fa8df79beb6f2f81164be51907d262 SHA512 e472b1c848aece2980e67134a27bc1cab4a531b048790b7b36638e618d59f3f3e8ddcb538cd24723135266899a02b7c8952a73d81c4848e672c21c99c40c5af0
DIST dafny-3.7.3-x64-ubuntu-16.04.zip 76169341 BLAKE2B eb8bee64a0bd39b8af0996e298590c83bcf306dbfda5bc486ef70b13187b4fc0131fd2b98d5eb1b87a3177b1f25c5cd64b82522e4d57cf1b0d2aa1eb34869789 SHA512 0bdda39e8ae22eff72bd57e4ef5f07495e27156b11ff553a2e1f76731d7daa5ce6ac4f4d8b16b3365eacbbd25bc81d88cbfece9a0350e2a0faac2a035f3d5561
+DIST dafny-3.8.0-x64-ubuntu-16.04.zip 76181911 BLAKE2B 9fbae78bb08ed448a164188758c53de6eb928f16e941ee2830c5d8ed3980e3f4ccdd4f1b99c30061a5838ef96dd71ad0ac4a69ffdf45ca8a428e37cbd1f8049d SHA512 43628709dfe34d91fda3b723e4f9deacace463a4002c520d62b319f3618b2e62dec93e2fd913926e41c8ef75dd3535a909c4eeb2e58e00faa6ffdd1f028f8277
diff --git a/dev-lang/dafny-bin/dafny-bin-3.8.0.ebuild b/dev-lang/dafny-bin/dafny-bin-3.8.0.ebuild
new file mode 100644
index 000000000000..39a827f48c53
--- /dev/null
+++ b/dev-lang/dafny-bin/dafny-bin-3.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Verification-aware programming language"
+HOMEPAGE="https://dafny.org/"
+SRC_URI="https://github.com/dafny-lang/dafny/releases/download/v${PV}/dafny-${PV}-x64-ubuntu-16.04.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64" # Binaries are compiled only for x86_64.
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ dev-libs/userspace-rcu
+ dev-util/lttng-ust
+ sci-mathematics/z3
+"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"/dafny
+QA_PREBUILT="*"
+
+src_prepare() {
+ default
+
+ # Remove bundled z3.
+ # NOTICE: New versions do not need the bundled one but older versions
+ # hardcoded the path relative to "dafny" binary.
+ # While bumping make sure to verify that system's "z3" is used
+ # by, for example, compiling/verifying a simple dafny program.
+ rm -r z3 || die
+}
+
+src_install() {
+ local dest=/opt/dafny
+
+ insinto ${dest}
+ # Maybe too general, but this installation mode matched how it arrives.
+ insopts -m0755
+ doins "${S}"/*
+
+ local bin
+ for bin in DafnyServer dafny ; do
+ dosym ../../${dest}/${bin} /usr/bin/${bin}
+ done
+
+ # Make "dafny-server" clients happy.
+ dosym ../../${dest}/DafnyServer /usr/bin/dafny-server
+}