summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-03-12 16:49:52 +0100
committerMichał Górny <mgorny@gentoo.org>2016-03-12 17:33:16 +0100
commit9bea49004a2fe8d150e3d3adc0bb852d5ed63b12 (patch)
treee4930f447aa7cfbf568e3cf75854e6a7c81bd7de /dev-lang/ekopath
parentsys-devel/gcc: mark 4.9.3 sparc stable #561844 (diff)
downloadgentoo-9bea49004a2fe8d150e3d3adc0bb852d5ed63b12.tar.gz
gentoo-9bea49004a2fe8d150e3d3adc0bb852d5ed63b12.tar.bz2
gentoo-9bea49004a2fe8d150e3d3adc0bb852d5ed63b12.zip
dev-lang/ekopath: Install versioned install dirs for future multislot
Diffstat (limited to 'dev-lang/ekopath')
-rw-r--r--dev-lang/ekopath/ekopath-6.0.619_p20151213-r100.ebuild (renamed from dev-lang/ekopath/ekopath-6.0.619_p20151213.ebuild)18
-rw-r--r--dev-lang/ekopath/ekopath-6.0.637_p20151231-r100.ebuild (renamed from dev-lang/ekopath/ekopath-6.0.637_p20151231.ebuild)18
-rw-r--r--dev-lang/ekopath/ekopath-6.0.661_p20160124-r100.ebuild (renamed from dev-lang/ekopath/ekopath-6.0.661_p20160124.ebuild)18
-rw-r--r--dev-lang/ekopath/ekopath-6.0.705_p20160303-r100.ebuild (renamed from dev-lang/ekopath/ekopath-6.0.705_p20160303.ebuild)18
-rw-r--r--dev-lang/ekopath/ekopath-6.0.713_p20160311-r100.ebuild76
-rw-r--r--dev-lang/ekopath/ekopath-6.0.713_p20160311.ebuild74
6 files changed, 116 insertions, 106 deletions
diff --git a/dev-lang/ekopath/ekopath-6.0.619_p20151213.ebuild b/dev-lang/ekopath/ekopath-6.0.619_p20151213-r100.ebuild
index c886d1352814..3711d115e5eb 100644
--- a/dev-lang/ekopath/ekopath-6.0.619_p20151213.ebuild
+++ b/dev-lang/ekopath/ekopath-6.0.619_p20151213-r100.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -7,6 +7,7 @@ EAPI=5
inherit versionator multilib pax-utils
MY_PV=$(get_version_component_range 1-3)
+MY_P=${PN}-${MY_PV}
DATE=$(get_version_component_range 4)
DATE=${DATE#p}
DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
@@ -27,8 +28,8 @@ RDEPEND=""
RESTRICT="bindist mirror"
QA_PREBUILT="
- opt/${PN}/lib/${MY_PV}/x8664/*
- opt/${PN}/bin/*"
+ opt/${MY_P}/lib/${MY_PV}/x8664/*
+ opt/${MY_P}/bin/*"
S="${WORKDIR}"
@@ -54,12 +55,12 @@ src_install() {
fi
./"${INSTALLER}" \
- --prefix "${ED%/}/opt/${PN}" \
+ --prefix "${ED%/}/opt/${MY_P}" \
--mode unattended || die
- if [[ ! -d ${ED%/}/opt/${PN}/lib/${MY_PV} ]]; then
+ if [[ ! -d ${ED%/}/opt/${MY_P}/lib/${MY_PV} ]]; then
local guess
- cd "${ED%/}/opt/${PN}/lib" && guess=( * )
+ cd "${ED%/}/opt/${MY_P}/lib" && guess=( * )
if [[ ${guess[@]} ]]; then
die "Incorrect release version in PV, guessing it should be: ${guess[*]}"
@@ -67,8 +68,9 @@ src_install() {
die "No libdir installed"
fi
fi
- [[ -x ${ED%}/opt/${PN}/bin/pathcc ]] || die "No pathcc executable was installed, your hardware is unsupported most likely"
+ [[ -x ${ED%}/opt/${MY_P}/bin/pathcc ]] || die "No pathcc executable was installed, your hardware is unsupported most likely"
- rm -r "${ED}/opt/${PN}"/uninstall* || die
+ rm -r "${ED}/opt/${MY_P}"/uninstall* || die
+ dosym ${MY_P} /opt/${PN}
doenvd 99${PN}
}
diff --git a/dev-lang/ekopath/ekopath-6.0.637_p20151231.ebuild b/dev-lang/ekopath/ekopath-6.0.637_p20151231-r100.ebuild
index c886d1352814..3711d115e5eb 100644
--- a/dev-lang/ekopath/ekopath-6.0.637_p20151231.ebuild
+++ b/dev-lang/ekopath/ekopath-6.0.637_p20151231-r100.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -7,6 +7,7 @@ EAPI=5
inherit versionator multilib pax-utils
MY_PV=$(get_version_component_range 1-3)
+MY_P=${PN}-${MY_PV}
DATE=$(get_version_component_range 4)
DATE=${DATE#p}
DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
@@ -27,8 +28,8 @@ RDEPEND=""
RESTRICT="bindist mirror"
QA_PREBUILT="
- opt/${PN}/lib/${MY_PV}/x8664/*
- opt/${PN}/bin/*"
+ opt/${MY_P}/lib/${MY_PV}/x8664/*
+ opt/${MY_P}/bin/*"
S="${WORKDIR}"
@@ -54,12 +55,12 @@ src_install() {
fi
./"${INSTALLER}" \
- --prefix "${ED%/}/opt/${PN}" \
+ --prefix "${ED%/}/opt/${MY_P}" \
--mode unattended || die
- if [[ ! -d ${ED%/}/opt/${PN}/lib/${MY_PV} ]]; then
+ if [[ ! -d ${ED%/}/opt/${MY_P}/lib/${MY_PV} ]]; then
local guess
- cd "${ED%/}/opt/${PN}/lib" && guess=( * )
+ cd "${ED%/}/opt/${MY_P}/lib" && guess=( * )
if [[ ${guess[@]} ]]; then
die "Incorrect release version in PV, guessing it should be: ${guess[*]}"
@@ -67,8 +68,9 @@ src_install() {
die "No libdir installed"
fi
fi
- [[ -x ${ED%}/opt/${PN}/bin/pathcc ]] || die "No pathcc executable was installed, your hardware is unsupported most likely"
+ [[ -x ${ED%}/opt/${MY_P}/bin/pathcc ]] || die "No pathcc executable was installed, your hardware is unsupported most likely"
- rm -r "${ED}/opt/${PN}"/uninstall* || die
+ rm -r "${ED}/opt/${MY_P}"/uninstall* || die
+ dosym ${MY_P} /opt/${PN}
doenvd 99${PN}
}
diff --git a/dev-lang/ekopath/ekopath-6.0.661_p20160124.ebuild b/dev-lang/ekopath/ekopath-6.0.661_p20160124-r100.ebuild
index c886d1352814..3711d115e5eb 100644
--- a/dev-lang/ekopath/ekopath-6.0.661_p20160124.ebuild
+++ b/dev-lang/ekopath/ekopath-6.0.661_p20160124-r100.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -7,6 +7,7 @@ EAPI=5
inherit versionator multilib pax-utils
MY_PV=$(get_version_component_range 1-3)
+MY_P=${PN}-${MY_PV}
DATE=$(get_version_component_range 4)
DATE=${DATE#p}
DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
@@ -27,8 +28,8 @@ RDEPEND=""
RESTRICT="bindist mirror"
QA_PREBUILT="
- opt/${PN}/lib/${MY_PV}/x8664/*
- opt/${PN}/bin/*"
+ opt/${MY_P}/lib/${MY_PV}/x8664/*
+ opt/${MY_P}/bin/*"
S="${WORKDIR}"
@@ -54,12 +55,12 @@ src_install() {
fi
./"${INSTALLER}" \
- --prefix "${ED%/}/opt/${PN}" \
+ --prefix "${ED%/}/opt/${MY_P}" \
--mode unattended || die
- if [[ ! -d ${ED%/}/opt/${PN}/lib/${MY_PV} ]]; then
+ if [[ ! -d ${ED%/}/opt/${MY_P}/lib/${MY_PV} ]]; then
local guess
- cd "${ED%/}/opt/${PN}/lib" && guess=( * )
+ cd "${ED%/}/opt/${MY_P}/lib" && guess=( * )
if [[ ${guess[@]} ]]; then
die "Incorrect release version in PV, guessing it should be: ${guess[*]}"
@@ -67,8 +68,9 @@ src_install() {
die "No libdir installed"
fi
fi
- [[ -x ${ED%}/opt/${PN}/bin/pathcc ]] || die "No pathcc executable was installed, your hardware is unsupported most likely"
+ [[ -x ${ED%}/opt/${MY_P}/bin/pathcc ]] || die "No pathcc executable was installed, your hardware is unsupported most likely"
- rm -r "${ED}/opt/${PN}"/uninstall* || die
+ rm -r "${ED}/opt/${MY_P}"/uninstall* || die
+ dosym ${MY_P} /opt/${PN}
doenvd 99${PN}
}
diff --git a/dev-lang/ekopath/ekopath-6.0.705_p20160303.ebuild b/dev-lang/ekopath/ekopath-6.0.705_p20160303-r100.ebuild
index c886d1352814..3711d115e5eb 100644
--- a/dev-lang/ekopath/ekopath-6.0.705_p20160303.ebuild
+++ b/dev-lang/ekopath/ekopath-6.0.705_p20160303-r100.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -7,6 +7,7 @@ EAPI=5
inherit versionator multilib pax-utils
MY_PV=$(get_version_component_range 1-3)
+MY_P=${PN}-${MY_PV}
DATE=$(get_version_component_range 4)
DATE=${DATE#p}
DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
@@ -27,8 +28,8 @@ RDEPEND=""
RESTRICT="bindist mirror"
QA_PREBUILT="
- opt/${PN}/lib/${MY_PV}/x8664/*
- opt/${PN}/bin/*"
+ opt/${MY_P}/lib/${MY_PV}/x8664/*
+ opt/${MY_P}/bin/*"
S="${WORKDIR}"
@@ -54,12 +55,12 @@ src_install() {
fi
./"${INSTALLER}" \
- --prefix "${ED%/}/opt/${PN}" \
+ --prefix "${ED%/}/opt/${MY_P}" \
--mode unattended || die
- if [[ ! -d ${ED%/}/opt/${PN}/lib/${MY_PV} ]]; then
+ if [[ ! -d ${ED%/}/opt/${MY_P}/lib/${MY_PV} ]]; then
local guess
- cd "${ED%/}/opt/${PN}/lib" && guess=( * )
+ cd "${ED%/}/opt/${MY_P}/lib" && guess=( * )
if [[ ${guess[@]} ]]; then
die "Incorrect release version in PV, guessing it should be: ${guess[*]}"
@@ -67,8 +68,9 @@ src_install() {
die "No libdir installed"
fi
fi
- [[ -x ${ED%}/opt/${PN}/bin/pathcc ]] || die "No pathcc executable was installed, your hardware is unsupported most likely"
+ [[ -x ${ED%}/opt/${MY_P}/bin/pathcc ]] || die "No pathcc executable was installed, your hardware is unsupported most likely"
- rm -r "${ED}/opt/${PN}"/uninstall* || die
+ rm -r "${ED}/opt/${MY_P}"/uninstall* || die
+ dosym ${MY_P} /opt/${PN}
doenvd 99${PN}
}
diff --git a/dev-lang/ekopath/ekopath-6.0.713_p20160311-r100.ebuild b/dev-lang/ekopath/ekopath-6.0.713_p20160311-r100.ebuild
new file mode 100644
index 000000000000..3711d115e5eb
--- /dev/null
+++ b/dev-lang/ekopath/ekopath-6.0.713_p20160311-r100.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit versionator multilib pax-utils
+
+MY_PV=$(get_version_component_range 1-3)
+MY_P=${PN}-${MY_PV}
+DATE=$(get_version_component_range 4)
+DATE=${DATE#p}
+DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
+INSTALLER=${PN}-${DATE}-installer.run
+
+DESCRIPTION="PathScale EKOPath Compiler Suite"
+HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
+SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${INSTALLER}"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="!!app-arch/rpm"
+RDEPEND=""
+
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="
+ opt/${MY_P}/lib/${MY_PV}/x8664/*
+ opt/${MY_P}/bin/*"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${INSTALLER}" "${S}/" || die
+ chmod +x "${S}/${INSTALLER}" || die
+}
+
+src_prepare() {
+ cat > 99${PN} <<-EOF || die
+ PATH=${EROOT%/}/opt/${PN}/bin
+ ROOTPATH=${EROOT%/}/opt/${PN}/bin
+ LDPATH=${EROOT%/}/opt/${PN}/lib:${EROOT%/}/opt/${PN}/lib/${MY_PV}/x8664/64
+ MANPATH=${EROOT%/}/opt/${PN}/docs/man
+ EOF
+}
+
+src_install() {
+ # EI_PAX marking is obsolete and PT_PAX breaks the binary.
+ # We must use XT_PAX to run the installer.
+ if [[ ${PAX_MARKINGS} == "XT" ]]; then
+ pax-mark m "${INSTALLER}"
+ fi
+
+ ./"${INSTALLER}" \
+ --prefix "${ED%/}/opt/${MY_P}" \
+ --mode unattended || die
+
+ if [[ ! -d ${ED%/}/opt/${MY_P}/lib/${MY_PV} ]]; then
+ local guess
+ cd "${ED%/}/opt/${MY_P}/lib" && guess=( * )
+
+ if [[ ${guess[@]} ]]; then
+ die "Incorrect release version in PV, guessing it should be: ${guess[*]}"
+ else
+ die "No libdir installed"
+ fi
+ fi
+ [[ -x ${ED%}/opt/${MY_P}/bin/pathcc ]] || die "No pathcc executable was installed, your hardware is unsupported most likely"
+
+ rm -r "${ED}/opt/${MY_P}"/uninstall* || die
+ dosym ${MY_P} /opt/${PN}
+ doenvd 99${PN}
+}
diff --git a/dev-lang/ekopath/ekopath-6.0.713_p20160311.ebuild b/dev-lang/ekopath/ekopath-6.0.713_p20160311.ebuild
deleted file mode 100644
index c886d1352814..000000000000
--- a/dev-lang/ekopath/ekopath-6.0.713_p20160311.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit versionator multilib pax-utils
-
-MY_PV=$(get_version_component_range 1-3)
-DATE=$(get_version_component_range 4)
-DATE=${DATE#p}
-DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
-INSTALLER=${PN}-${DATE}-installer.run
-
-DESCRIPTION="PathScale EKOPath Compiler Suite"
-HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
-SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${INSTALLER}"
-
-LICENSE="all-rights-reserved"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="!!app-arch/rpm"
-RDEPEND=""
-
-RESTRICT="bindist mirror"
-
-QA_PREBUILT="
- opt/${PN}/lib/${MY_PV}/x8664/*
- opt/${PN}/bin/*"
-
-S="${WORKDIR}"
-
-src_unpack() {
- cp "${DISTDIR}/${INSTALLER}" "${S}/" || die
- chmod +x "${S}/${INSTALLER}" || die
-}
-
-src_prepare() {
- cat > 99${PN} <<-EOF || die
- PATH=${EROOT%/}/opt/${PN}/bin
- ROOTPATH=${EROOT%/}/opt/${PN}/bin
- LDPATH=${EROOT%/}/opt/${PN}/lib:${EROOT%/}/opt/${PN}/lib/${MY_PV}/x8664/64
- MANPATH=${EROOT%/}/opt/${PN}/docs/man
- EOF
-}
-
-src_install() {
- # EI_PAX marking is obsolete and PT_PAX breaks the binary.
- # We must use XT_PAX to run the installer.
- if [[ ${PAX_MARKINGS} == "XT" ]]; then
- pax-mark m "${INSTALLER}"
- fi
-
- ./"${INSTALLER}" \
- --prefix "${ED%/}/opt/${PN}" \
- --mode unattended || die
-
- if [[ ! -d ${ED%/}/opt/${PN}/lib/${MY_PV} ]]; then
- local guess
- cd "${ED%/}/opt/${PN}/lib" && guess=( * )
-
- if [[ ${guess[@]} ]]; then
- die "Incorrect release version in PV, guessing it should be: ${guess[*]}"
- else
- die "No libdir installed"
- fi
- fi
- [[ -x ${ED%}/opt/${PN}/bin/pathcc ]] || die "No pathcc executable was installed, your hardware is unsupported most likely"
-
- rm -r "${ED}/opt/${PN}"/uninstall* || die
- doenvd 99${PN}
-}