summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-06-09 20:04:07 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-06-09 20:09:16 +0100
commit456fe14669aabfe1a94367fd4c331d2644e18001 (patch)
tree25eba58394311cbe3995930f1629ef83a07cf6c9 /dev-lang/ghc/files
parentdev-ada/gprbuild: Version bump to dev-ada/gprbuild-2018 (diff)
downloadgentoo-456fe14669aabfe1a94367fd4c331d2644e18001.tar.gz
gentoo-456fe14669aabfe1a94367fd4c331d2644e18001.tar.bz2
gentoo-456fe14669aabfe1a94367fd4c331d2644e18001.zip
dev-lang/ghc: bump up to 8.4.3, no binaries yet
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-lang/ghc/files')
-rw-r--r--dev-lang/ghc/files/ghc-8.0.2-no-relax-everywhere.patch17
-rw-r--r--dev-lang/ghc/files/ghc-8.4.2-allow-cross-bootstrap.patch23
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-lang/ghc/files/ghc-8.0.2-no-relax-everywhere.patch b/dev-lang/ghc/files/ghc-8.0.2-no-relax-everywhere.patch
new file mode 100644
index 000000000000..d6cff3373801
--- /dev/null
+++ b/dev-lang/ghc/files/ghc-8.0.2-no-relax-everywhere.patch
@@ -0,0 +1,17 @@
+https://github.com/gentoo-haskell/gentoo-haskell/issues/704
+
+Allow users to specify -W,--relax externally and pass
+-Wl,-no-relax unconditonally on all arches.
+
+Reported-by: wmyrda
+diff --git a/compiler/main/DriverPipeline.hs b/compiler/main/DriverPipeline.hs
+index acd0d61..5830517 100644
+--- a/compiler/main/DriverPipeline.hs
++++ b/compiler/main/DriverPipeline.hs
+@@ -2172,5 +2172,3 @@ joinObjectFiles dflags o_files output_fn = do
+ -- disable --relax explicitly.
+- ++ (if platformArch (targetPlatform dflags)
+- `elem` [ArchSPARC, ArchSPARC64]
+- && ldIsGnuLd
++ ++ (if ldIsGnuLd
+ then [SysTools.Option "-Wl,-no-relax"]
diff --git a/dev-lang/ghc/files/ghc-8.4.2-allow-cross-bootstrap.patch b/dev-lang/ghc/files/ghc-8.4.2-allow-cross-bootstrap.patch
new file mode 100644
index 000000000000..071d4970a25b
--- /dev/null
+++ b/dev-lang/ghc/files/ghc-8.4.2-allow-cross-bootstrap.patch
@@ -0,0 +1,23 @@
+Allow using cross-compilers to bootstrap GHC.
+
+In my case I'm using "cross"-compiler from
+x86_64-unknown-linux to x86_64-HEAD-linux.
+
+Those targets have the same ABI and can boot one another.
+diff --git a/configure.ac b/configure.ac
+index a8b8681a36..791367e8bf 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -228,11 +228,11 @@ FPTOOLS_SET_PLATFORM_VARS
+ if test "$BuildPlatform" != "$bootstrap_target"
+ then
+ echo "This GHC (${WithGhc}) does not generate code for the build platform"
+ echo " GHC target platform : $bootstrap_target"
+ echo " Desired build platform : $BuildPlatform"
+- exit 1
++ #exit 1
+ fi
+
+ # Testing if we shall enable shared libs support on Solaris.
+ # Anything older than SunOS 5.11 aka Solaris 11 (Express) is broken.
+