summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-07-22 00:20:13 +0100
committerMarek Szuba <marecki@gentoo.org>2021-07-22 01:19:06 +0100
commitce93f9058c4336109e35afc150ff9677dabfaf05 (patch)
tree9872ae1525a3feadd560a1fcc6f012a8d34e1a5f /dev-lang/go
parentmedia-gfx/povray: keyword 3.7.0.0-r1 for ~riscv (diff)
downloadgentoo-ce93f9058c4336109e35afc150ff9677dabfaf05.tar.gz
gentoo-ce93f9058c4336109e35afc150ff9677dabfaf05.tar.bz2
gentoo-ce93f9058c4336109e35afc150ff9677dabfaf05.zip
dev-lang/go: keyword 1.16.6 for ~riscv
For the time being only rv64 is supported in tc-arch() -> GOARCH translation - which however is fine for now because upstream does not support rv32 out of the box yet. Builds, tests and installs fine - with the caveat that since riscv is not supported by dev-lang/go-bootstrap yet, it is necessary to start by cross-building a dev-lang/go somewhere where Go is already present. Bug: https://bugs.gentoo.org/794046 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-lang/go')
-rw-r--r--dev-lang/go/go-1.16.6.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-lang/go/go-1.16.6.ebuild b/dev-lang/go/go-1.16.6.ebuild
index 4c8f5c8fbc88..895ddad58f5e 100644
--- a/dev-lang/go/go-1.16.6.ebuild
+++ b/dev-lang/go/go-1.16.6.ebuild
@@ -21,7 +21,7 @@ case ${PV} in
case ${PV} in
*_beta*|*_rc*) ;;
*)
- KEYWORDS="-* amd64 arm arm64 ~ppc64 ~s390 x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ KEYWORDS="-* amd64 arm arm64 ~ppc64 ~riscv ~s390 x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
;;
esac
esac
@@ -63,6 +63,7 @@ go_arch() {
x86) echo 386;;
x64-*) echo amd64;;
ppc64) [[ $(tc-endian $@) = big ]] && echo ppc64 || echo ppc64le ;;
+ riscv) echo riscv64 ;;
s390) echo s390x ;;
*) echo "${portage_arch}";;
esac