summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2015-11-23 19:34:12 +0800
committerJason Zaman <perfinion@gentoo.org>2015-11-23 19:34:40 +0800
commit1ed77efedf7b762cea57373c02b299862198ea2f (patch)
tree54e54fcaddf4119aad91558c2d934bfa4162492a /dev-lang/mono/mono-2.10.9-r2.ebuild
parentdev-python/elasticsearch-curator: rm old versions (diff)
downloadgentoo-1ed77efedf7b762cea57373c02b299862198ea2f.tar.gz
gentoo-1ed77efedf7b762cea57373c02b299862198ea2f.tar.bz2
gentoo-1ed77efedf7b762cea57373c02b299862198ea2f.zip
dev-lang/mono: do not call paxctl directly
paxmark.sh should be used instead which follows XT/PT marks correctly Gentoo-Bug: https://bugs.gentoo.org/532244 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-lang/mono/mono-2.10.9-r2.ebuild')
-rw-r--r--dev-lang/mono/mono-2.10.9-r2.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-lang/mono/mono-2.10.9-r2.ebuild b/dev-lang/mono/mono-2.10.9-r2.ebuild
index 8f938146451f..0938c29b2636 100644
--- a/dev-lang/mono/mono-2.10.9-r2.ebuild
+++ b/dev-lang/mono/mono-2.10.9-r2.ebuild
@@ -64,9 +64,10 @@ src_prepare() {
# we need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it doesn't
# get killed in the build process when MPROTECT is enabled. #286280
# RANDMMAP kills the build process to #347365
+ # use paxmark.sh to get PT/XT logic #532244
if use pax_kernel ; then
ewarn "We are disabling MPROTECT on the mono binary."
- sed '/exec "/ i\paxctl-ng -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
+ sed '/exec "/ i\paxmark.sh -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
fi
}