summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-12-04 00:29:58 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-12-04 00:35:35 +0000
commit62efaec77fa10f6a5d44cef700300b659d8b48d6 (patch)
tree91ecd418bdb5a150641dc0ba144e415f41a168d2 /dev-lang/nim
parentdev-lang/php: x86 stable (bug #756775) (diff)
downloadgentoo-62efaec77fa10f6a5d44cef700300b659d8b48d6.tar.gz
gentoo-62efaec77fa10f6a5d44cef700300b659d8b48d6.tar.bz2
gentoo-62efaec77fa10f6a5d44cef700300b659d8b48d6.zip
dev-lang/nim: bump up to 1.4.2
Among other things nimble source is bundled again and we can build it by default. Reported-by: Anthony Parsons Closes: https://bugs.gentoo.org/752411 Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-lang/nim')
-rw-r--r--dev-lang/nim/Manifest1
-rw-r--r--dev-lang/nim/nim-1.4.2.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/dev-lang/nim/Manifest b/dev-lang/nim/Manifest
index fefbe21022b5..7ddfaada80f9 100644
--- a/dev-lang/nim/Manifest
+++ b/dev-lang/nim/Manifest
@@ -1 +1,2 @@
DIST nim-1.4.0.tar.xz 4626604 BLAKE2B 09417508b840d4cb522006f0dddd8799cb235db5f4e2f18fdf970ffa4d845998e498c005843cc994e15f8bea992b5341c8bce667208c68bf81ce3f5e650627bc SHA512 aa0cd5aef16ad5e793dc2c021404c1f0b89b35829f155ada4c0795d980de722493fb4e3da45373e6f2597b5af71140f5ecdfd5b06aa26e9afd2eb5d3f2cab8df
+DIST nim-1.4.2.tar.xz 4770616 BLAKE2B 95561a22fedaa1eb42f099589b7b13e6833d1804d1d9bf8c4ec6514a4db89622d7f678b19ce9bed1c3ac5dffa3956b73e6b12fa6335f8e39a8b0dee90ae50457 SHA512 a357eaa5ef6c71b296fe6c53ed25be8b864a2895871a4ef6f23f2d31ce1c17d6dfb12eaf2bb8e71d122b7cf46746873109f424388ac2b6e84826699c1c5493fe
diff --git a/dev-lang/nim/nim-1.4.2.ebuild b/dev-lang/nim/nim-1.4.2.ebuild
new file mode 100644
index 000000000000..75756c7f47da
--- /dev/null
+++ b/dev-lang/nim/nim-1.4.2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 multiprocessing toolchain-funcs
+
+DESCRIPTION="compiled, garbage-collected systems programming language"
+HOMEPAGE="https://nim-lang.org/"
+SRC_URI="https://nim-lang.org/download/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc +readline test"
+
+RESTRICT=test # need to sort out depends and numerous failures
+
+RDEPEND="
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="
+ ${DEPEND}
+ test? ( net-libs/nodejs )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.20.0-paths.patch
+)
+
+_run() {
+ echo "$@"
+ "$@" || die "'$*' failed"
+}
+
+nim_use_enable() {
+ [[ -z $2 ]] && die "usage: nim_use_enable <USE flag> <compiler flag>"
+ use $1 && echo "-d:$2"
+}
+
+src_configure() {
+ export XDG_CACHE_HOME=${T}/cache #667182
+ tc-export CC LD
+
+ # Override default CC=gcc.
+ echo "gcc.exe = \"$(tc-getCC)\"" >> config/nim.cfg || die
+ echo "gcc.linkerexe = \"$(tc-getCC)\"" >> config/nim.cfg || die
+}
+
+src_compile() {
+
+ _run ./build.sh
+
+ _run ./bin/nim --parallelBuild:$(makeopts_jobs) c koch
+ _run ./koch boot --parallelBuild:$(makeopts_jobs) -d:release $(nim_use_enable readline useGnuReadline)
+ PATH="./bin:$PATH" _run ./koch tools --parallelBuild:$(makeopts_jobs)
+
+ if use doc; then
+ # TODO: '--parallelBuild:' does ont seem to work
+ PATH="./bin:$PATH" _run ./koch doc --parallelBuild:$(makeopts_jobs)
+ fi
+}
+
+src_test() {
+ PATH="./bin:$PATH" _run ./koch test --parallelBuild:$(makeopts_jobs)
+}
+
+src_install() {
+ PATH="./bin:$PATH" _run ./koch install "${ED}"
+ rm -r "${ED}/usr/share/nim/doc" || die "failed to remove 'doc'"
+
+ exeinto /usr/bin
+
+ local bin_exe
+ for bin_exe in bin/*; do
+ # './koch install' installs only 'nim' binary
+ # but not the rest
+ [[ ${bin_exe} == bin/nim ]] && continue
+ doexe "${bin_exe}"
+ done
+
+ use doc && dodoc doc/html/*.html
+ newbashcomp tools/nim.bash-completion ${PN}
+}