summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-10 14:04:31 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-10 14:25:41 +0100
commit0e58d227abb00aee2b1f6c55201a8c3227829a3e (patch)
tree756e17bbf8444e79c674e1d388f6005f02adc551 /dev-lang/rust
parentdev-cpp/gtest: Remove py2 where possible (diff)
downloadgentoo-0e58d227abb00aee2b1f6c55201a8c3227829a3e.tar.gz
gentoo-0e58d227abb00aee2b1f6c55201a8c3227829a3e.tar.bz2
gentoo-0e58d227abb00aee2b1f6c55201a8c3227829a3e.zip
dev-lang/rust: Remove py2 where possible
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/rust-1.37.0.ebuild2
-rw-r--r--dev-lang/rust/rust-1.38.0.ebuild2
-rw-r--r--dev-lang/rust/rust-1.39.0.ebuild2
-rw-r--r--dev-lang/rust/rust-1.40.0-r1.ebuild2
-rw-r--r--dev-lang/rust/rust-1.41.0.ebuild2
5 files changed, 5 insertions, 5 deletions
diff --git a/dev-lang/rust/rust-1.37.0.ebuild b/dev-lang/rust/rust-1.37.0.ebuild
index 542c7dc00d17..f7294f8494a0 100644
--- a/dev-lang/rust/rust-1.37.0.ebuild
+++ b/dev-lang/rust/rust-1.37.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit check-reqs estack flag-o-matic llvm multiprocessing multilib-build python-any-r1 rust-toolchain toolchain-funcs
diff --git a/dev-lang/rust/rust-1.38.0.ebuild b/dev-lang/rust/rust-1.38.0.ebuild
index 23b7ca132b18..c4e9d3cf9ee9 100644
--- a/dev-lang/rust/rust-1.38.0.ebuild
+++ b/dev-lang/rust/rust-1.38.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit check-reqs estack flag-o-matic llvm multiprocessing multilib-build python-any-r1 rust-toolchain toolchain-funcs
diff --git a/dev-lang/rust/rust-1.39.0.ebuild b/dev-lang/rust/rust-1.39.0.ebuild
index d369e43890ff..caf6bb4b5809 100644
--- a/dev-lang/rust/rust-1.39.0.ebuild
+++ b/dev-lang/rust/rust-1.39.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit bash-completion-r1 check-reqs estack flag-o-matic llvm multiprocessing multilib-build python-any-r1 rust-toolchain toolchain-funcs
diff --git a/dev-lang/rust/rust-1.40.0-r1.ebuild b/dev-lang/rust/rust-1.40.0-r1.ebuild
index 8be040d0227c..8ac9b0156ead 100644
--- a/dev-lang/rust/rust-1.40.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.40.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit bash-completion-r1 check-reqs estack flag-o-matic llvm multiprocessing multilib-build python-any-r1 rust-toolchain toolchain-funcs
diff --git a/dev-lang/rust/rust-1.41.0.ebuild b/dev-lang/rust/rust-1.41.0.ebuild
index 0139d999763d..064abcea32b3 100644
--- a/dev-lang/rust/rust-1.41.0.ebuild
+++ b/dev-lang/rust/rust-1.41.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit bash-completion-r1 check-reqs estack flag-o-matic llvm multiprocessing multilib-build python-any-r1 rust-toolchain toolchain-funcs