summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-06-01 23:56:00 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-06-01 23:56:00 +0200
commit7300c9fed56cdccef654d1ac2e1635064df767ff (patch)
treefd221ab95fafd6897409bcfb32d751040263c348 /dev-lang/typescript
parentdev-lang/typescript: drop old 5.0.3 (diff)
downloadgentoo-7300c9fed56cdccef654d1ac2e1635064df767ff.tar.gz
gentoo-7300c9fed56cdccef654d1ac2e1635064df767ff.tar.bz2
gentoo-7300c9fed56cdccef654d1ac2e1635064df767ff.zip
dev-lang/typescript: bump to 5.1.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang/typescript')
-rw-r--r--dev-lang/typescript/Manifest1
-rw-r--r--dev-lang/typescript/typescript-5.1.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-lang/typescript/Manifest b/dev-lang/typescript/Manifest
index 1866e8000741..b70e9dccd04c 100644
--- a/dev-lang/typescript/Manifest
+++ b/dev-lang/typescript/Manifest
@@ -1,2 +1,3 @@
DIST typescript-4.9.5.tgz 11620433 BLAKE2B c253379a4aadd3fe16c93f27c5b450e5965c4c4de6841737c3489c74baa2cf8f8f5d9ca0414b5519e26eaac1db058e3826a3aa504bb450a89d36dce7e21b5f99 SHA512 d455e4f44d879be433650ef3f8c7098872f8356d45d84cccbbd36af62df301a1aa89b69fa98c02554e96c9602ec90451cce971a2ef31652c972c437ca0a8f6e2
DIST typescript-5.0.4.tgz 7051452 BLAKE2B ed08425d8324a910f2d328fb02f27e08f75334fb190d1c4625452d076d615726d0e852da06f0f25146a4b02c6c99cd569bbcf7c50f5d6ff32c88a40101a59656 SHA512 716f53e56f71637edc73e8df127694bd7f757e8c6d1e4cdadcdc37c24a05e2c4a52a7d0c38d7647449dd8a0fea3c15973649a9961dcdcdac90cc2887338fe1ab
+DIST typescript-5.1.3.tgz 7147721 BLAKE2B 5a18d18bcbe702c82a108624c189e6b03d72f74e16ccf6af2448c71c1decfcc7995b53524472e106c19ef01ec95df772ccfeed3e76fad1eb59f29bbe42668fb0 SHA512 5c7eb6ec4f6f91eaa1959150b8bf94b3201712789b4f491647615638d96be2c4e3bf1c89627c9e7e0ae4c8408bccce4d7a798acd1032dab47f3a560b0351e467
diff --git a/dev-lang/typescript/typescript-5.1.3.ebuild b/dev-lang/typescript/typescript-5.1.3.ebuild
new file mode 100644
index 000000000000..598301d43b33
--- /dev/null
+++ b/dev-lang/typescript/typescript-5.1.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Superset of JavaScript with optional static typing, classes and interfaces"
+HOMEPAGE="https://www.typescriptlang.org/
+ https://github.com/microsoft/TypeScript/"
+SRC_URI="https://registry.npmjs.org/${PN}/-/${P}.tgz"
+S="${WORKDIR}"/package
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+RDEPEND="net-libs/nodejs"
+BDEPEND=">=net-libs/nodejs-16[npm]"
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local myopts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}"/usr
+ --progress false
+ --verbose
+ )
+ npm ${myopts[@]} install "${DISTDIR}"/${P}.tgz || die "npm install failed"
+
+ dodoc *.md *.txt
+}