summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-05-31 10:42:51 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-05-31 10:43:50 -0700
commit1eec1bfb2d551241c3d4e67ecacf2f0c89e76632 (patch)
treee88cf030582ea965fc9895b689cec3490ff85207 /dev-lang
parentRevert "sci-mathematics/coq: drop old 8.11.2-r1" (diff)
downloadgentoo-1eec1bfb2d551241c3d4e67ecacf2f0c89e76632.tar.gz
gentoo-1eec1bfb2d551241c3d4e67ecacf2f0c89e76632.tar.bz2
gentoo-1eec1bfb2d551241c3d4e67ecacf2f0c89e76632.zip
dev-lang/rust: pass static-libstdcpp = false for libcxx build
Bug: https://bugs.gentoo.org/732632 Thanks-to: Jonas Rakebrandt <xarblu@protonmail.com> Tested-by: Manuel Nickschas <sputnick@quassel-irc.org> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust/rust-1.61.0-r1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-lang/rust/rust-1.61.0-r1.ebuild b/dev-lang/rust/rust-1.61.0-r1.ebuild
index 250c7e2f1db2..40bfa3387e3e 100644
--- a/dev-lang/rust/rust-1.61.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.61.0-r1.ebuild
@@ -327,7 +327,10 @@ src_configure() {
targets = "${LLVM_TARGETS// /;}"
experimental-targets = ""
link-shared = $(toml_usex system-llvm)
- use-libcxx = ${use_libcxx}
+ $(if [[ ${use_libcxx} == true ]]; then
+ echo "use-libcxx = true"
+ echo "static-libstdcpp = false"
+ fi)
$(case "${rust_target}" in
i586-*-linux-*)
# https://github.com/rust-lang/rust/issues/93059